# GHSA-vq4j-qcx7-ppc6: Thelia Cross-site Scripting vulnerability in BackOffice

> An attacker can inject malicious scripts into the Thelia BackOffice error template, potentially compromising administrator sessions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 May 2024

## What is GHSA-vq4j-qcx7-ppc6?

GHSA-vq4j-qcx7-ppc6 is a cross-site scripting vulnerability in thelia/thelia, published on 30 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The BackOffice of Thelia (`error.html` template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.

## Which versions are affected by GHSA-vq4j-qcx7-ppc6?

2 open source packages ship an affected version, including thelia/thelia.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thelia/thelia` | Packagist | From 2.1.0 | 2.1.2 |
| `thelia/thelia` | Packagist | From 2.1.0 | 2.1.2 |

## How do I fix GHSA-vq4j-qcx7-ppc6?

Upgrade thelia/thelia to 2.1.2 or later.

## Is GHSA-vq4j-qcx7-ppc6 being exploited?

There is no known exploitation of GHSA-vq4j-qcx7-ppc6 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-vq4j-qcx7-ppc6 and fix it if it is affected.

What it is: GHSA-vq4j-qcx7-ppc6 is a cross-site scripting vulnerability in thelia/thelia, published on 30 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-vq4j-qcx7-ppc6 in the wild and no public exploit code.

Affected packages and fixed versions:
- thelia/thelia (Packagist): affected from 2.1.0; fixed in 2.1.2
- thelia/thelia (Packagist): affected from 2.1.0; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-vq4j-qcx7-ppc6/ (Markdown: https://insights.sbomify.com/GHSA-vq4j-qcx7-ppc6/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-vq4j-qcx7-ppc6

---
From sbomify Insights: https://insights.sbomify.com/GHSA-vq4j-qcx7-ppc6/
Summaries are generated and may contain mistakes; the official description above is the record.
