{"answers":{"affected":"2 open source packages ship an affected version, including laravel/framework.","exploited":"There is no known exploitation of GHSA-vr95-p7q6-8m9q in the wild and no public exploit code.","fix":"Upgrade laravel/framework to 7.1.2 or later.","what":"GHSA-vr95-p7q6-8m9q is a cross-site scripting vulnerability in laravel/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-vr95-p7q6-8m9q and fix it if it is affected.\n\nWhat it is: GHSA-vr95-p7q6-8m9q is a cross-site scripting vulnerability in laravel/framework, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-vr95-p7q6-8m9q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- laravel/framework (Packagist): affected from 7.0.0; fixed in 7.1.2\n- laravel/framework (Packagist): affected from 7.0.0; fixed in 7.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vr95-p7q6-8m9q/ (Markdown: https://insights.sbomify.com/GHSA-vr95-p7q6-8m9q/index.md)","id":"GHSA-vr95-p7q6-8m9q","markdown":"https://insights.sbomify.com/GHSA-vr95-p7q6-8m9q/index.md","name":"GHSA-vr95-p7q6-8m9q","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel framework","requires_auth":"none","summary":"Attackers can inject malicious scripts via Blade component attributes if user input is not sanitized, affecting Laravel 7.x users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Laravel 7.1.2 addresses a possible XSS related attack vector in the Laravel 7.x Blade Component tag attributes when users are allowed to dictate the value of attributes. All Laravel 7.x users are encouraged to upgrade as soon as possible.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Laravel Cross-site Scripting (XSS) vulnerability in blade templating","id":"GHSA-vr95-p7q6-8m9q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"laravel/framework","purl":null,"source":"GHSA-vr95-p7q6-8m9q"},{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"laravel/framework","purl":"pkg:composer/laravel/framework","source":"GHSA-vr95-p7q6-8m9q"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject malicious scripts via Blade component attributes if user input is not sanitized, affecting Laravel 7.x users.","url":"https://insights.sbomify.com/GHSA-vr95-p7q6-8m9q/"}