{"answers":{"affected":"2 open source packages ship an affected version, including auth0/wordpress.","exploited":"There is no known exploitation of GHSA-vvg7-8rmq-92g7 in the wild and no public exploit code.","fix":"Upgrade auth0/wordpress to 5.5.0 or later.","what":"GHSA-vvg7-8rmq-92g7 is an authentication bypass vulnerability in auth0/wordpress, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vvg7-8rmq-92g7 and fix it if it is affected.\n\nWhat it is: GHSA-vvg7-8rmq-92g7 is an authentication bypass vulnerability in auth0/wordpress, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vvg7-8rmq-92g7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/wordpress (Packagist): affected from 5.0.0-BETA0; fixed in 5.5.0\n- auth0/wordpress (Packagist): affected from 5.0.0-BETA0; fixed in 5.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vvg7-8rmq-92g7/ (Markdown: https://insights.sbomify.com/GHSA-vvg7-8rmq-92g7/index.md)","id":"GHSA-vvg7-8rmq-92g7","markdown":"https://insights.sbomify.com/GHSA-vvg7-8rmq-92g7/index.md","name":"GHSA-vvg7-8rmq-92g7","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Improper audience validation in Auth0 WordPress plugin allows accepting ID tokens as Access tokens, bypassing authentication checks.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Description\nIn applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.\n\n### Affected product and versions\nProjects are affected if they meet the following preconditions:\n\n- Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0,\n- Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.\n\n### Resolution\nUpgrade Auth0 Wordpress plugin to version 5.5.0 or greater.\n\n### Acknowledgement\nOkta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency","id":"GHSA-vvg7-8rmq-92g7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.5.0"],"introduced":["5.0.0-BETA0"],"last_affected":[],"package":"auth0/wordpress","purl":null,"source":"GHSA-vvg7-8rmq-92g7"},{"ecosystem":"Packagist","fixed":["5.5.0"],"introduced":["5.0.0-BETA0"],"last_affected":[],"package":"auth0/wordpress","purl":"pkg:composer/auth0/wordpress","source":"GHSA-vvg7-8rmq-92g7"}],"products":null,"published":"2025-12-17","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Improper audience validation in Auth0 WordPress plugin allows accepting ID tokens as Access tokens, bypassing authentication checks.","url":"https://insights.sbomify.com/GHSA-vvg7-8rmq-92g7/"}