{"answers":{"affected":"2 open source packages ship an affected version, including DSInternals.Common.","exploited":"There is no known exploitation of GHSA-vx2x-9cff-fhjw in the wild and no public exploit code.","fix":"Upgrade DSInternals.Common to 4.8 or later.","what":"GHSA-vx2x-9cff-fhjw is a path traversal vulnerability in DSInternals.Common, published on 6 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vx2x-9cff-fhjw and fix it if it is affected.\n\nWhat it is: GHSA-vx2x-9cff-fhjw is a path traversal vulnerability in DSInternals.Common, published on 6 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vx2x-9cff-fhjw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DSInternals.Common (NuGet): affected from 2.21; fixed in 4.8\n- DSInternals.Common (NuGet): affected from 2.21; fixed in 4.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vx2x-9cff-fhjw/ (Markdown: https://insights.sbomify.com/GHSA-vx2x-9cff-fhjw/index.md)","id":"GHSA-vx2x-9cff-fhjw","markdown":"https://insights.sbomify.com/GHSA-vx2x-9cff-fhjw/index.md","name":"GHSA-vx2x-9cff-fhjw","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"DSInternals library","requires_auth":"low_privilege","summary":"A path traversal vulnerability in DSInternals allows attackers with AD write access to modify files on systems running privileged applications using the library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nA vulnerability exists in the `DSInternals.Common.Data.RoamedCredential.Save()` method, which incorrectly parses the `msPKIAccountCredentials` LDAP attribute values. As a consequence, a malicious actor would be able to modify the file system of the computer where an application using this function is executed with administrative privileges.\n\nA [similar security issue](https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-30170) used to be present in the Windows operating system, as DSInternals re-implements the Credential Roaming feature of Windows.\n\n### Exploitability\n\nThe vulnerability can be exploited under the following circumstances:\n- An attacker is able to modify the `msPKIAccountCredentials` attribute of a user account in Active Directory. This attribute is used by the Credential Roaming feature of Windows and each AD user can modify their own roamed credentials. AND\n- A 3rd party application uses the `DSInternals.Common` library to export roamed credentials from Active Directory to a file system. AND\n- The application has administrative privileges on the local system.\n\nThe probability of any 3rd-party product using the `DSInternals.Common` library being affected by this vulnerability is extremely low.\n\n### Patches\n\nThe issue had been fixed in DSInternals 4.8.\n\n### References\n\nhttps://www.mandiant.com/resources/blog/apt29-windows-credential-roaming","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"DSInternals Credential Roaming Elevation of Privilege Vulnerability","id":"GHSA-vx2x-9cff-fhjw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["4.8"],"introduced":["2.21"],"last_affected":[],"package":"DSInternals.Common","purl":null,"source":"GHSA-vx2x-9cff-fhjw"},{"ecosystem":"NuGet","fixed":["4.8"],"introduced":["2.21"],"last_affected":[],"package":"DSInternals.Common","purl":"pkg:nuget/DSInternals.Common","source":"GHSA-vx2x-9cff-fhjw"}],"products":null,"published":"2022-12-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A path traversal vulnerability in DSInternals allows attackers with AD write access to modify files on systems running privileged applications using the library.","url":"https://insights.sbomify.com/GHSA-vx2x-9cff-fhjw/"}