{"answers":{"affected":"2 open source packages ship an affected version, including inventree.","exploited":"There is no known exploitation of GHSA-vx3h-qwqw-r2wq in the wild and no public exploit code.","fix":"Upgrade inventree to 0.16.5 or later.","what":"GHSA-vx3h-qwqw-r2wq is a server-side request forgery vulnerability in inventree, published on 2 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vx3h-qwqw-r2wq and fix it if it is affected.\n\nWhat it is: GHSA-vx3h-qwqw-r2wq is a server-side request forgery vulnerability in inventree, published on 2 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vx3h-qwqw-r2wq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- inventree (PyPI): affected all versions; fixed in 0.16.5\n- inventree (PyPI): affected all versions; fixed in 0.16.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vx3h-qwqw-r2wq/ (Markdown: https://insights.sbomify.com/GHSA-vx3h-qwqw-r2wq/index.md)","id":"GHSA-vx3h-qwqw-r2wq","markdown":"https://insights.sbomify.com/GHSA-vx3h-qwqw-r2wq/index.md","name":"GHSA-vx3h-qwqw-r2wq","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"InvenTree inventory system","requires_auth":"low_privilege","summary":"Attackers can exploit the remote image download feature to extract sensitive server-side information via error messages, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe \"download image from remote URL\" feature can be abused by a malicious actor to potentially extract information about server side resources. Submitting a crafted URL (in place of a valid image) can raise a server side error, which is reported back to the user. \n\nThis error message may contain sensitive information about the server side request, including information about the availability of the remote resource.\n\n### Patches\n\nThe solution to this vulnerability is to prevent the server from returning any specific information about the observed exception. Instead, a generic error message is returned to the client.\n\nThis patch has been applied to the upcoming 0.17.0 release, and also back-ported to the 0.16.5 stable release.\n\n### Workarounds\n\nTo avoid this issue with unpatched versions, the \"download image from remote URL\" feature can be disabled in InvenTree, preventing users from accessing this information. \n\n### References\n\nThanks to @febin0x10 for identifying this vulnerability and reporting it to us as per our security policy.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Inventree Server-Side Request Forgery vulnerability exposes server port/internal IP","id":"GHSA-vx3h-qwqw-r2wq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.16.5"],"introduced":["0"],"last_affected":[],"package":"inventree","purl":null,"source":"GHSA-vx3h-qwqw-r2wq"},{"ecosystem":"PyPI","fixed":["0.16.5"],"introduced":["0"],"last_affected":[],"package":"inventree","purl":"pkg:pypi/inventree","source":"GHSA-vx3h-qwqw-r2wq"}],"products":null,"published":"2024-10-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit the remote image download feature to extract sensitive server-side information via error messages, requiring an upgrade to fix.","url":"https://insights.sbomify.com/GHSA-vx3h-qwqw-r2wq/"}