{"answers":{"affected":"2 open source packages ship an affected version, including github.com/nghttp2/nghttp2.","exploited":"There is no known exploitation of GHSA-vx74-f528-fxqg in the wild and no public exploit code.","fix":"Upgrade github.com/nghttp2/nghttp2 to 1.57.0 or later.","what":"GHSA-vx74-f528-fxqg is a denial of service vulnerability in github.com/nghttp2/nghttp2, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-vx74-f528-fxqg and fix it if it is affected.\n\nWhat it is: GHSA-vx74-f528-fxqg is a denial of service vulnerability in github.com/nghttp2/nghttp2, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-vx74-f528-fxqg in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/nghttp2/nghttp2 (Go): affected all versions; fixed in 1.57.0\n- github.com/nghttp2/nghttp2 (Go): affected all versions; fixed in 1.57.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-vx74-f528-fxqg/ (Markdown: https://insights.sbomify.com/GHSA-vx74-f528-fxqg/index.md)","id":"GHSA-vx74-f528-fxqg","markdown":"https://insights.sbomify.com/GHSA-vx74-f528-fxqg/index.md","name":"GHSA-vx74-f528-fxqg","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HTTP/2 library","requires_auth":"none","summary":"Attackers can cause denial of service by rapidly creating and cancelling HTTP/2 streams, affecting applications using the nghttp2 library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nRapidly creating and cancelling streams (HEADERS frame immediately followed by RST_STREAM) without bound cause denial of service.\n\nSee https://www.cve.org/CVERecord?id=CVE-2023-44487 for details.\n\n### Patches\n\nnghttp2 v1.57.0 mitigates this vulnerability by default.\n\n### Workarounds\n\nIf upgrading to nghttp2 v1.57.0 is not possible, implement `nghttp2_on_frame_recv_callback`, and check and count RST_STREAM frames.  If excessive number of RST_STREAM are received, then take action, such as dropping connection silently, or call `nghttp2_submit_goaway` and gracefully terminate the connection.\n\n### References\n\nThe following commit mitigates this vulnerability:\n\n- https://github.com/nghttp2/nghttp2/commit/72b4af6143681f528f1d237b21a9a7aee1738832","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"github.com/nghttp2/nghttp2 has HTTP/2 Rapid Reset","id":"GHSA-vx74-f528-fxqg","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["1.57.0"],"introduced":["0"],"last_affected":[],"package":"github.com/nghttp2/nghttp2","purl":null,"source":"GHSA-vx74-f528-fxqg"},{"ecosystem":"Go","fixed":["1.57.0"],"introduced":["0"],"last_affected":[],"package":"github.com/nghttp2/nghttp2","purl":"pkg:golang/github.com/nghttp2/nghttp2","source":"GHSA-vx74-f528-fxqg"}],"products":null,"published":"2023-10-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service by rapidly creating and cancelling HTTP/2 streams, affecting applications using the nghttp2 library.","url":"https://insights.sbomify.com/GHSA-vx74-f528-fxqg/"}