{"answers":{"affected":"2 open source packages ship an affected version, including opencv-contrib-python-headless.","exploited":"There is no known exploitation of GHSA-w2pj-9cgh-mq2c in the wild and no public exploit code.","fix":"Upgrade opencv-contrib-python-headless to 4.8.1.78 or later.","what":"GHSA-w2pj-9cgh-mq2c is a memory corruption vulnerability in opencv-contrib-python-headless, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-w2pj-9cgh-mq2c and fix it if it is affected.\n\nWhat it is: GHSA-w2pj-9cgh-mq2c is a memory corruption vulnerability in opencv-contrib-python-headless, published on 30 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-w2pj-9cgh-mq2c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.8.1.78\n- opencv-contrib-python-headless (PyPI): affected all versions; fixed in 4.8.1.78\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w2pj-9cgh-mq2c/ (Markdown: https://insights.sbomify.com/GHSA-w2pj-9cgh-mq2c/index.md)","id":"GHSA-w2pj-9cgh-mq2c","markdown":"https://insights.sbomify.com/GHSA-w2pj-9cgh-mq2c/index.md","name":"GHSA-w2pj-9cgh-mq2c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python OpenCV library","requires_auth":"none","summary":"Attackers can execute arbitrary code or cause denial of service by tricking users into processing malicious WebP images via the vulnerable bundled libwebp library.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"opencv-contrib-python-headless versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. opencv-contrib-python-headless v4.8.1.78 upgrades the bundled libwebp binary to v1.3.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"opencv-contrib-python-headless bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863","id":"GHSA-w2pj-9cgh-mq2c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["4.8.1.78"],"introduced":["0"],"last_affected":[],"package":"opencv-contrib-python-headless","purl":null,"source":"GHSA-w2pj-9cgh-mq2c"},{"ecosystem":"PyPI","fixed":["4.8.1.78"],"introduced":["0"],"last_affected":[],"package":"opencv-contrib-python-headless","purl":"pkg:pypi/opencv-contrib-python-headless","source":"GHSA-w2pj-9cgh-mq2c"}],"products":null,"published":"2024-08-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code or cause denial of service by tricking users into processing malicious WebP images via the vulnerable bundled libwebp library.","url":"https://insights.sbomify.com/GHSA-w2pj-9cgh-mq2c/"}