# GHSA-w2vw-w76x-qr89: Nx: OS command injection via git revisions and remote refs

> Attackers can execute arbitrary commands on developer machines and CI runners by controlling git revisions or remote refs in Nx projects.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2026

## What is GHSA-w2vw-w76x-qr89?

GHSA-w2vw-w76x-qr89 is a command injection vulnerability in nx, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

## Summary

Nx core builds several `git` invocations as shell command strings with untrusted values interpolated into them, so a value that should be a git revision or ref is parsed by `/bin/sh` instead. Two entry points are reachable by an attacker: `affected` commands, where `defaultBase` / `affected.defaultBase` from `nx.json` (and the `NX_BASE` / `NX_HEAD` environment variables) reach `git merge-base` and `git diff`; and `nx import`, where a branch name advertised by a remote repository reaches `git fetch`, `git checkout`, and `git config`. In both cases an attacker who controls a repository — or who opens a pull request against one — gets arbitrary command execution on the machine of anyone who runs an ordinary Nx command against it, including CI runners.

The `affected` path is the more serious of the two. `nx affected` and `nx show projects --affected` run constantly in CI, so a pull request that changes nothing but `nx.json` is enough to execute code on the runner with whatever credentials that job holds.

## Severity

Exploitable by anyone who controls repository content — a fork's pull request, or a repository the victim clones — that the victim then runs an ordinary `nx affected` or `nx import` against; no access to the victim's machine is required. We have no evidence of exploitation in the wild.

## Affected & Patched Versions

| Package | Vulnerable | Patched |
| --- | --- | --- |
| `nx` | `>= 14.0.0, < 22.7.8`; `>= 23.0.0, < 23.1.1` | `22.7.8`, `23.1.1` |

Treat every version below the patched ones as affected.

## Remediation

Upgrade to **22.7.8** (22.x line) or **23.1.1** (23.x line) or later:

```
nx migrate 23.1.1
```

The fix is a drop-in — no configuration changes are required. If you cannot upgrade, treat `nx.json` from untrusted sources as executable content, do not run `affected` commands against pull requests you have not reviewed, and do not run `nx import` against repositories you do not trust.

## Details

### `affected` commands

Nx computes the merge base and the changed-file set by building `git merge-base` and `git diff` command lines as strings and running them through a shell. The base and head revisions in those strings come from `nx.json`'s `defaultBase` / `affected.defaultBase` or from the `NX_BASE` / `NX_HEAD` environment variables, and a related code path reads file contents with `git show <revision>:<path>` the same way. Because a shell parses the whole line, a revision value containing shell syntax is executed rather than passed to `git`.

The revisions are wrapped in double quotes, which looks protective but is not: POSIX shells still perform command substitution inside double quotes, so a value of `$(…)` runs without needing to break out of the quotes.

### `nx import`

The `GitRepository` helper runs every git operation — `fetch`, `checkout`, `reset`, `config`, and others — by interpolating its arguments into a shell command string. The untrusted argument is a branch name: `nx import` lists the branches a remote advertises, offers them to the user to choose from, and feeds the chosen name back into those commands. A hostile repository controls the names of its own branches, so it controls the command that runs when one is selected.

## Credits

- **Arkadiusz Marta** (RE:SOURCE) — Reporter

## Which versions are affected by GHSA-w2vw-w76x-qr89?

4 open source packages ship an affected version, including nx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nx` | npm | From 14.0.0 | 22.7.8 |
| `nx` | npm | From 14.0.0 | 22.7.8 |
| `nx` | npm | From 23.0.0 | 23.1.1 |
| `nx` | npm | From 23.0.0 | 23.1.1 |

## How do I fix GHSA-w2vw-w76x-qr89?

Upgrade nx to a fixed version for your release line: 22.7.8 or 23.1.1.

## Is GHSA-w2vw-w76x-qr89 being exploited?

There is no known exploitation of GHSA-w2vw-w76x-qr89 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-w2vw-w76x-qr89 and fix it if it is affected.

What it is: GHSA-w2vw-w76x-qr89 is a command injection vulnerability in nx, published on 5 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-w2vw-w76x-qr89 in the wild and no public exploit code.

Affected packages and fixed versions:
- nx (npm): affected from 14.0.0; fixed in 22.7.8
- nx (npm): affected from 14.0.0; fixed in 22.7.8
- nx (npm): affected from 23.0.0; fixed in 23.1.1
- nx (npm): affected from 23.0.0; fixed in 23.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-w2vw-w76x-qr89/ (Markdown: https://insights.sbomify.com/GHSA-w2vw-w76x-qr89/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-w2vw-w76x-qr89

---
From sbomify Insights: https://insights.sbomify.com/GHSA-w2vw-w76x-qr89/
Summaries are generated and may contain mistakes; the official description above is the record.
