{"answers":{"affected":"2 open source packages ship an affected version, including open-webui.","exploited":"There is no known exploitation of GHSA-w466-2wfc-8g58 in the wild and no public exploit code.","fix":"Upgrade open-webui to 0.5.8 or later.","what":"GHSA-w466-2wfc-8g58 is a denial of service vulnerability in open-webui, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-w466-2wfc-8g58 and fix it if it is affected.\n\nWhat it is: GHSA-w466-2wfc-8g58 is a denial of service vulnerability in open-webui, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-w466-2wfc-8g58 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- open-webui (PyPI): affected all versions; fixed in 0.5.8\n- open-webui (PyPI): affected all versions; fixed in 0.5.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w466-2wfc-8g58/ (Markdown: https://insights.sbomify.com/GHSA-w466-2wfc-8g58/index.md)","id":"GHSA-w466-2wfc-8g58","markdown":"https://insights.sbomify.com/GHSA-w466-2wfc-8g58/index.md","name":"GHSA-w466-2wfc-8g58","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Open WebUI","requires_auth":"none","summary":"An attacker can cause denial of service via memory exhaustion in Open WebUI due to a vulnerable Starlette dependency.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"In version 0.3.32 of open-webui, the application uses a vulnerable version of the starlette package through its dependency on fastapi. The starlette package versions \u003c=0.49 are susceptible to uncontrolled resource consumption, which can be exploited to cause a denial of service through memory exhaustion. This issue is addressed in fastapi version 0.115.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Open WebUI has vulnerable dependency on starlette via fastapi","id":"GHSA-w466-2wfc-8g58","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.5.8"],"introduced":["0"],"last_affected":[],"package":"open-webui","purl":null,"source":"GHSA-w466-2wfc-8g58"},{"ecosystem":"PyPI","fixed":["0.5.8"],"introduced":["0"],"last_affected":[],"package":"open-webui","purl":"pkg:pypi/open-webui","source":"GHSA-w466-2wfc-8g58"}],"products":null,"published":"2025-03-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause denial of service via memory exhaustion in Open WebUI due to a vulnerable Starlette dependency.","url":"https://insights.sbomify.com/GHSA-w466-2wfc-8g58/"}