# GHSA-w466-2wfc-8g58: Open WebUI has vulnerable dependency on starlette via fastapi

> An attacker can cause denial of service via memory exhaustion in Open WebUI due to a vulnerable Starlette dependency.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025

## What is GHSA-w466-2wfc-8g58?

GHSA-w466-2wfc-8g58 is a denial of service vulnerability in open-webui, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In version 0.3.32 of open-webui, the application uses a vulnerable version of the starlette package through its dependency on fastapi. The starlette package versions <=0.49 are susceptible to uncontrolled resource consumption, which can be exploited to cause a denial of service through memory exhaustion. This issue is addressed in fastapi version 0.115.3.

## Which versions are affected by GHSA-w466-2wfc-8g58?

2 open source packages ship an affected version, including open-webui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.5.8 |
| `open-webui` | PyPI | All versions | 0.5.8 |

## How do I fix GHSA-w466-2wfc-8g58?

Upgrade open-webui to 0.5.8 or later.

## Is GHSA-w466-2wfc-8g58 being exploited?

There is no known exploitation of GHSA-w466-2wfc-8g58 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-w466-2wfc-8g58 and fix it if it is affected.

What it is: GHSA-w466-2wfc-8g58 is a denial of service vulnerability in open-webui, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-w466-2wfc-8g58 in the wild and no public exploit code.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.5.8
- open-webui (PyPI): affected all versions; fixed in 0.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-w466-2wfc-8g58/ (Markdown: https://insights.sbomify.com/GHSA-w466-2wfc-8g58/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-w466-2wfc-8g58

---
From sbomify Insights: https://insights.sbomify.com/GHSA-w466-2wfc-8g58/
Summaries are generated and may contain mistakes; the official description above is the record.
