{"answers":{"affected":"2 open source packages ship an affected version, including uv.","exploited":"There is no known exploitation of GHSA-w476-p2h3-79g9 in the wild and no public exploit code.","fix":"Upgrade uv to 0.9.5 or later.","what":"GHSA-w476-p2h3-79g9 is a vulnerability in uv, published on 21 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-w476-p2h3-79g9 and fix it if it is affected.\n\nWhat it is: GHSA-w476-p2h3-79g9 is a vulnerability in uv, published on 21 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-w476-p2h3-79g9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uv (PyPI): affected all versions; fixed in 0.9.5\n- uv (PyPI): affected all versions; fixed in 0.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w476-p2h3-79g9/ (Markdown: https://insights.sbomify.com/GHSA-w476-p2h3-79g9/index.md)","id":"GHSA-w476-p2h3-79g9","markdown":"https://insights.sbomify.com/GHSA-w476-p2h3-79g9/index.md","name":"GHSA-w476-p2h3-79g9","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python package installer","requires_auth":"none","summary":"An attacker can craft a malicious tar archive that extracts differently in uv, potentially leading to code execution during installation.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nIn versions 0.9.4 and earlier of uv, tar archives containing PAX headers with file size overrides were not handled properly. As a result, an attacker could contrive a source distribution (as a tar archive) that would extract differently when installed via uv versus other Python package installers.\n\nThe underlying parsing differential here originates with astral-tokio-tar, which disclosed this vulnerability as CVE-2025-62518.\n\nIn practice, the impact of this vulnerability is **low**: only source distributions can be formatted as tar archives, and source distributions execute arbitrary code at build/installation time by definition. Consequently, a parser differential in tar extraction is strictly less powerful than the capabilities already exposed to an attacker who has the ability to control source distributions. \n\nHowever, this particular source of malleability in source distributions is unintentional and not operating by design, and therefore we consider it a vulnerability despite its overlap in capabilities with intended behavior.\n\n### Patches\n\nVersions 0.9.5 and newer of uv address the vulnerability above. Users should upgrade to 0.9.5 or newer.\n\n### Workarounds\n\nUsers are advised to upgrade to version 0.9.5 or newer to address this advisory.\n\nUsers should experience no breaking changes as a result of the patch above.\n\n### References\n\n* See CVE-2025-62518 for the corresponding advisory against astral-tokio-tar","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"uv has differential in tar extraction with PAX headers","id":"GHSA-w476-p2h3-79g9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.9.5"],"introduced":["0"],"last_affected":[],"package":"uv","purl":null,"source":"GHSA-w476-p2h3-79g9"},{"ecosystem":"PyPI","fixed":["0.9.5"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:pypi/uv","source":"GHSA-w476-p2h3-79g9"}],"products":null,"published":"2025-10-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can craft a malicious tar archive that extracts differently in uv, potentially leading to code execution during installation.","url":"https://insights.sbomify.com/GHSA-w476-p2h3-79g9/"}