{"answers":{"affected":"2 open source packages ship an affected version, including github.com/google/fscrypt.","exploited":"There is no known exploitation of GHSA-w4f8-fxq2-j35v in the wild and no public exploit code.","fix":"Upgrade github.com/google/fscrypt to 0.3.3 or later.","what":"GHSA-w4f8-fxq2-j35v is a command injection vulnerability in github.com/google/fscrypt, published on 1 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-w4f8-fxq2-j35v and fix it if it is affected.\n\nWhat it is: GHSA-w4f8-fxq2-j35v is a command injection vulnerability in github.com/google/fscrypt, published on 1 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-w4f8-fxq2-j35v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n- github.com/google/fscrypt (Go): affected all versions; fixed in 0.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w4f8-fxq2-j35v/ (Markdown: https://insights.sbomify.com/GHSA-w4f8-fxq2-j35v/index.md)","id":"GHSA-w4f8-fxq2-j35v","markdown":"https://insights.sbomify.com/GHSA-w4f8-fxq2-j35v/index.md","name":"GHSA-w4f8-fxq2-j35v","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"fscrypt CLI tool","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges by crafting malicious mountpoint paths that trigger command injection in the fscrypt bash completion script.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The bash completion script for `fscrypt` through v0.3.2 allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the `fscrypt` bash completion script to complete mountpoint paths. We recommend upgrading to v0.3.3 or above.\n\nFor more details, see [CVE-2022-25328](https://www.cve.org/CVERecord?id=CVE-2022-25328).","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Possible privilege escalation via bash completion script","id":"GHSA-w4f8-fxq2-j35v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":null,"source":"GHSA-w4f8-fxq2-j35v"},{"ecosystem":"Go","fixed":["0.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/google/fscrypt","purl":"pkg:golang/github.com/google/fscrypt","source":"GHSA-w4f8-fxq2-j35v"}],"products":null,"published":"2022-03-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Local attackers can escalate privileges by crafting malicious mountpoint paths that trigger command injection in the fscrypt bash completion script.","url":"https://insights.sbomify.com/GHSA-w4f8-fxq2-j35v/"}