{"answers":{"affected":"2 open source packages ship an affected version, including agents.","exploited":"There is no known exploitation of GHSA-w5cr-2qhr-jqc5 in the wild and no public exploit code.","fix":"Upgrade agents to 0.3.10 or later.","what":"GHSA-w5cr-2qhr-jqc5 is a cross-site scripting vulnerability in agents, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-w5cr-2qhr-jqc5 and fix it if it is affected.\n\nWhat it is: GHSA-w5cr-2qhr-jqc5 is a cross-site scripting vulnerability in agents, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-w5cr-2qhr-jqc5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- agents (npm): affected all versions; fixed in 0.3.10\n- agents (npm): affected all versions; fixed in 0.3.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w5cr-2qhr-jqc5/ (Markdown: https://insights.sbomify.com/GHSA-w5cr-2qhr-jqc5/index.md)","id":"GHSA-w5cr-2qhr-jqc5","markdown":"https://insights.sbomify.com/GHSA-w5cr-2qhr-jqc5/index.md","name":"GHSA-w5cr-2qhr-jqc5","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloudflare Agents SDK","requires_auth":"none","summary":"Reflected XSS in Cloudflare Agents SDK allows attackers to steal chat history and interact with MCP servers via malicious links.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Summary\n\nA Reflected Cross-Site Scripting (XSS) vulnerability was discovered in the AI Playground's OAuth callback handler. The error_description query parameter was directly interpolated into an HTML script tag without proper escaping, allowing attackers to execute arbitrary JavaScript in the context of the victim's session.\n\n### Root cause\n\nThe OAuth callback handler in `site/ai-playground/src/server.ts` directly interpolated the `authError` value, sourced from the `error_description` query parameter,  into an inline `\u003cscript\u003e` tag.\n\n### Impact\n\nAn attacker could craft a malicious link that, when clicked by a victim, would:\n- Steal user chat message history \n- Access all LLM interactions stored in the user's session.\n- Access connected MCP Servers \n- Interact with any MCP servers connected to the victim's session (public or authenticated/private), potentially allowing the attacker to perform actions on the victim's behalf\n\n### Mitigation:\n\n- PR: https://github.com/cloudflare/agents/pull/841\n- Agents-sdk users should upgrade to `agents@0.3.10`\n- Developers using `configureOAuthCallback` with custom error handling in their own applications should ensure all user-controlled input is escaped before interpolation.\n\n### Credits\n\nDisclosed responsibly by Nishant Kumawat","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cloudflare Agents has a Reflected Cross-Site Scripting (XSS) vulnerability in AI Playground site","id":"GHSA-w5cr-2qhr-jqc5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.3.10"],"introduced":["0"],"last_affected":[],"package":"agents","purl":null,"source":"GHSA-w5cr-2qhr-jqc5"},{"ecosystem":"npm","fixed":["0.3.10"],"introduced":["0"],"last_affected":[],"package":"agents","purl":"pkg:npm/agents","source":"GHSA-w5cr-2qhr-jqc5"}],"products":null,"published":"2026-02-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Reflected XSS in Cloudflare Agents SDK allows attackers to steal chat history and interact with MCP servers via malicious links.","url":"https://insights.sbomify.com/GHSA-w5cr-2qhr-jqc5/"}