{"answers":{"affected":"6 open source packages ship an affected version, including github.com/go-git/go-git/v5 and github.com/go-git/go-git/v6.","exploited":"There is no known exploitation of GHSA-w5pp-99ch-qj29 in the wild and no public exploit code.","fix":"Upgrade github.com/go-git/go-git/v5 to 5.19.1 or later.","what":"GHSA-w5pp-99ch-qj29 is a denial of service vulnerability in github.com/go-git/go-git/v5, published on 29 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-w5pp-99ch-qj29 and fix it if it is affected.\n\nWhat it is: GHSA-w5pp-99ch-qj29 is a denial of service vulnerability in github.com/go-git/go-git/v5, published on 29 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-w5pp-99ch-qj29 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.19.1\n- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.19.1\n- github.com/go-git/go-git/v5 (Go): affected all versions; fixed in 5.19.1\n- github.com/go-git/go-git/v6 (Go): affected all versions; fixed in 6.0.0-alpha.4\n- github.com/go-git/go-git/v6 (Go): affected all versions; fixed in 6.0.0-alpha.4\n- github.com/go-git/go-git/v6 (Go): affected all versions; fixed in 6.0.0-alpha.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w5pp-99ch-qj29/ (Markdown: https://insights.sbomify.com/GHSA-w5pp-99ch-qj29/index.md)","id":"GHSA-w5pp-99ch-qj29","markdown":"https://insights.sbomify.com/GHSA-w5pp-99ch-qj29/index.md","name":"GHSA-w5pp-99ch-qj29","record":{"aliases":["GO-2026-5693"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Go Git library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using go-git by providing malicious Git object data, requiring local file access or malicious remote interaction.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nSeveral denial-of-service issues were identified in `go-git` when parsing maliciously crafted Git repository data.\n\nAn attacker may craft a malicious `.pack`, `.idx` or loose objects that causes an application using an affected version of `go-git` to panic or consume excessive resources.\n\nThis can lead to denial of service in applications that use `go-git` to clone, fetch, open, or otherwise process untrusted repositories or Git object data.\n\nExploitation requires the ability to alter read-only files such as `.pack` or `.idx` from the local repository's `.git/objects/pack/` directory. Alternatively, the user would need to be interacting with a malicious remote server, which is not recommended and exposes users to a broader class of security risks beyond this issue.\n\n### Patches\nUsers should upgrade to a patched version in order to mitigate this vulnerability. Versions prior to `v5` are likely to be affected, users are recommended to upgrade to a supported `go-git` version.\n\n### Credits\ngo-git thanks @kodareef5, @AyushParkara and @N0zoM1z0 for reporting this in four separate reports. 🙇","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"go-git: Malformed Git object data may cause panics or resource exhaustion","id":"GHSA-w5pp-99ch-qj29","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["5.19.1"],"introduced":["0"],"last_affected":[],"package":"github.com/go-git/go-git/v5","purl":null,"source":"GHSA-w5pp-99ch-qj29"},{"ecosystem":"Go","fixed":["5.19.1"],"introduced":["0"],"last_affected":[],"package":"github.com/go-git/go-git/v5","purl":"pkg:golang/github.com/go-git/go-git/v5","source":"GHSA-w5pp-99ch-qj29"},{"ecosystem":"Go","fixed":["5.19.1"],"introduced":["0"],"last_affected":[],"package":"github.com/go-git/go-git/v5","purl":"pkg:golang/github.com/go-git/go-git/v5","source":"GO-2026-5693"},{"ecosystem":"Go","fixed":["6.0.0-alpha.4"],"introduced":["0"],"last_affected":[],"package":"github.com/go-git/go-git/v6","purl":null,"source":"GHSA-w5pp-99ch-qj29"},{"ecosystem":"Go","fixed":["6.0.0-alpha.4"],"introduced":["0"],"last_affected":[],"package":"github.com/go-git/go-git/v6","purl":"pkg:golang/github.com/go-git/go-git/v6","source":"GHSA-w5pp-99ch-qj29"},{"ecosystem":"Go","fixed":["6.0.0-alpha.4"],"introduced":["0"],"last_affected":[],"package":"github.com/go-git/go-git/v6","purl":"pkg:golang/github.com/go-git/go-git/v6","source":"GO-2026-5693"}],"products":null,"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in applications using go-git by providing malicious Git object data, requiring local file access or malicious remote interaction.","url":"https://insights.sbomify.com/GHSA-w5pp-99ch-qj29/"}