{"answers":{"affected":"2 open source packages ship an affected version, including typeorm.","exploited":"There is no known exploitation of GHSA-w7q7-vjp8-7jv4 in the wild and no public exploit code.","fix":"Upgrade typeorm to 0.1.15 or later.","what":"GHSA-w7q7-vjp8-7jv4 is a SQL injection vulnerability in typeorm, published on 6 Jun 2019. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-w7q7-vjp8-7jv4 and fix it if it is affected.\n\nWhat it is: GHSA-w7q7-vjp8-7jv4 is a SQL injection vulnerability in typeorm, published on 6 Jun 2019. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-w7q7-vjp8-7jv4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- typeorm (npm): affected all versions; fixed in 0.1.15\n- typeorm (npm): affected all versions; fixed in 0.1.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w7q7-vjp8-7jv4/ (Markdown: https://insights.sbomify.com/GHSA-w7q7-vjp8-7jv4/index.md)","id":"GHSA-w7q7-vjp8-7jv4","markdown":"https://insights.sbomify.com/GHSA-w7q7-vjp8-7jv4/index.md","name":"GHSA-w7q7-vjp8-7jv4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ORM library","requires_auth":"unknown","summary":"Attackers can inject SQL statements via unvalidated field names in TypeORM, allowing arbitrary query execution and data manipulation.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `typeorm` before 0.1.15 are vulnerable to SQL Injection. Field names are not properly validated allowing attackers to inject SQL statements and execute arbitrary SQL queries.\n\n## Recommendation\n\nUpgrade to version 0.1.15","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"SQL Injection in typeorm","id":"GHSA-w7q7-vjp8-7jv4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.1.15"],"introduced":["0"],"last_affected":[],"package":"typeorm","purl":null,"source":"GHSA-w7q7-vjp8-7jv4"},{"ecosystem":"npm","fixed":["0.1.15"],"introduced":["0"],"last_affected":[],"package":"typeorm","purl":"pkg:npm/typeorm","source":"GHSA-w7q7-vjp8-7jv4"}],"products":null,"published":"2019-06-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject SQL statements via unvalidated field names in TypeORM, allowing arbitrary query execution and data manipulation.","url":"https://insights.sbomify.com/GHSA-w7q7-vjp8-7jv4/"}