{"answers":{"affected":"2 open source packages ship an affected version, including @vitejs/plugin-rsc.","exploited":"There is no known exploitation of GHSA-w94c-4vhp-22gx in the wild and no public exploit code.","fix":"Upgrade @vitejs/plugin-rsc to 0.5.26 or later.","what":"GHSA-w94c-4vhp-22gx is a denial of service vulnerability in @vitejs/plugin-rsc, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-w94c-4vhp-22gx and fix it if it is affected.\n\nWhat it is: GHSA-w94c-4vhp-22gx is a denial of service vulnerability in @vitejs/plugin-rsc, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-w94c-4vhp-22gx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @vitejs/plugin-rsc (npm): affected all versions; fixed in 0.5.26\n- @vitejs/plugin-rsc (npm): affected all versions; fixed in 0.5.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w94c-4vhp-22gx/ (Markdown: https://insights.sbomify.com/GHSA-w94c-4vhp-22gx/index.md)","id":"GHSA-w94c-4vhp-22gx","markdown":"https://insights.sbomify.com/GHSA-w94c-4vhp-22gx/index.md","name":"GHSA-w94c-4vhp-22gx","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Vite React plugin","requires_auth":"none","summary":"Attackers can cause denial of service in applications using @vitejs/plugin-rsc due to a vulnerability in the vendored React Server Components library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\n`@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.6. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh\n\n### Patches\n\nUpgrade immediately to `@vitejs/plugin-rsc@0.5.26` or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"@vitejs/plugin-rsc has a Denial of Service Vulnerability in React Server Components","id":"GHSA-w94c-4vhp-22gx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.5.26"],"introduced":["0"],"last_affected":[],"package":"@vitejs/plugin-rsc","purl":null,"source":"GHSA-w94c-4vhp-22gx"},{"ecosystem":"npm","fixed":["0.5.26"],"introduced":["0"],"last_affected":[],"package":"@vitejs/plugin-rsc","purl":"pkg:npm/%40vitejs/plugin-rsc","source":"GHSA-w94c-4vhp-22gx"}],"products":null,"published":"2026-05-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in applications using @vitejs/plugin-rsc due to a vulnerability in the vendored React Server Components library.","url":"https://insights.sbomify.com/GHSA-w94c-4vhp-22gx/"}