{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-w9j9-w4cp-6wgr in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.4.8 or later.","what":"GHSA-w9j9-w4cp-6wgr is a code injection vulnerability in openclaw, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-w9j9-w4cp-6wgr and fix it if it is affected.\n\nWhat it is: GHSA-w9j9-w4cp-6wgr is a code injection vulnerability in openclaw, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-w9j9-w4cp-6wgr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.4.8\n- openclaw (npm): affected all versions; fixed in 2026.4.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w9j9-w4cp-6wgr/ (Markdown: https://insights.sbomify.com/GHSA-w9j9-w4cp-6wgr/index.md)","id":"GHSA-w9j9-w4cp-6wgr","markdown":"https://insights.sbomify.com/GHSA-w9j9-w4cp-6wgr/index.md","name":"GHSA-w9j9-w4cp-6wgr","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenClaw npm package","requires_auth":"none","summary":"OpenClaw host-exec could inherit environment variables allowing code injection, requiring an upgrade to the patched npm version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\nOpenClaw Host-Exec Environment Variable Injection.\n\nHost exec could inherit environment variables that influence interpreters, shells, or build tools.\n\nOpenClaw is a user-controlled local assistant. This advisory is scoped to the OpenClaw trust model and does not assume a multi-tenant service boundary.\n\n## Affected Packages / Versions\n\n- Package: `openclaw` (npm)\n- Affected versions: `\u003c= 2026.3.28`\n- Patched versions: `2026.4.8`\n\n## Fix\n\nThe issue was fixed on `main` and is available in the patched npm version listed above. The verified fixed tree is commit `d7c3210cd6f5fdfdc1beff4c9541673e814354d5`.\n\n## Verification\n\nThe fix was re-checked against `main` before publication, including targeted regression tests for the affected security boundary.\n\n## Credits\n\nThanks @wsparks-vc for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw Host-Exec Environment Variable Injection","id":"GHSA-w9j9-w4cp-6wgr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.4.8"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-w9j9-w4cp-6wgr"},{"ecosystem":"npm","fixed":["2026.4.8"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-w9j9-w4cp-6wgr"}],"products":null,"published":"2026-04-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"OpenClaw host-exec could inherit environment variables allowing code injection, requiring an upgrade to the patched npm version.","url":"https://insights.sbomify.com/GHSA-w9j9-w4cp-6wgr/"}