{"answers":{"affected":"2 open source packages ship an affected version, including ezsystems/platform-ui-assets-bundle.","exploited":"There is no known exploitation of GHSA-w9p3-26fx-5mp3 in the wild and no public exploit code.","fix":"Upgrade ezsystems/platform-ui-assets-bundle to 4.2.3 or later.","what":"GHSA-w9p3-26fx-5mp3 is a cross-site scripting vulnerability in ezsystems/platform-ui-assets-bundle, published on 15 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-w9p3-26fx-5mp3 and fix it if it is affected.\n\nWhat it is: GHSA-w9p3-26fx-5mp3 is a cross-site scripting vulnerability in ezsystems/platform-ui-assets-bundle, published on 15 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-w9p3-26fx-5mp3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/platform-ui-assets-bundle (Packagist): affected from 4.2.0; fixed in 4.2.3\n- ezsystems/platform-ui-assets-bundle (Packagist): affected from 4.2.0; fixed in 4.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-w9p3-26fx-5mp3/ (Markdown: https://insights.sbomify.com/GHSA-w9p3-26fx-5mp3/index.md)","id":"GHSA-w9p3-26fx-5mp3","markdown":"https://insights.sbomify.com/GHSA-w9p3-26fx-5mp3/index.md","name":"GHSA-w9p3-26fx-5mp3","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"eZ Platform Admin UI","requires_auth":"low_privilege","summary":"Attackers can inject scripts via crafted comments or view unauthorized draft titles in the review queue, requiring updates to CKEditor and workflow components.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"There is an XSS vulnerability in CKEditor, which is used by AlloyEditor, which is used in eZ Platform Admin UI. Scripts can be injected through specially crafted \"protected\" comments. We are not sure it is exploitable in eZ Platform, but recommend installing it to be on the safe side. It is fixed in CKEditor v4.14, AlloyEditor v2.11.9. It is distributed via Composer, for:\n```\neZ Platform v1.13.x: ezsystems/PlatformUIAssetsBundle v4.2.3 (included from ezsystems/PlatformUIBundle v1.13.x)\n\neZ Platform v2.5.13: ezsystems/ezplatform-admin-ui-assets v4.2.1\n\neZ Platform v3.0.*: ezsystems/ezplatform-admin-ui-assets v5.0.1\n\neZ Platform v3.1.2: ezsystems/ezplatform-admin-ui-assets v5.1.1\n```\n\nDrafts that are sent to trash become visible in the Review Queue, even for users that were not able to see them before this action. It's not possible to preview them, but their title and review history is displayed. This affects Enterprise Edition only, of which ezplatform-workflow is a part. This security update is distributed via Composer, for\n```\neZ Platform EE v2.5.13: ezsystems/ezplatform-workflow v1.1.9\n\neZ Platform EE v3.1.2: ezsystems/ezplatform-workflow v2.1.1\n```","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"eZ Platform Admin UI is vulnerable to Cross-site Scripting (XSS)","id":"GHSA-w9p3-26fx-5mp3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.2.3"],"introduced":["4.2.0"],"last_affected":[],"package":"ezsystems/platform-ui-assets-bundle","purl":null,"source":"GHSA-w9p3-26fx-5mp3"},{"ecosystem":"Packagist","fixed":["4.2.3"],"introduced":["4.2.0"],"last_affected":[],"package":"ezsystems/platform-ui-assets-bundle","purl":"pkg:composer/ezsystems/platform-ui-assets-bundle","source":"GHSA-w9p3-26fx-5mp3"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject scripts via crafted comments or view unauthorized draft titles in the review queue, requiring updates to CKEditor and workflow components.","url":"https://insights.sbomify.com/GHSA-w9p3-26fx-5mp3/"}