{"answers":{"affected":"2 open source packages ship an affected version, including c2cciutils.","exploited":"There is no known exploitation of GHSA-wcjx-v2wj-xg87 in the wild and no public exploit code.","fix":"Upgrade c2cciutils to 1.1.66 or later.","what":"GHSA-wcjx-v2wj-xg87 is a denial of service vulnerability in c2cciutils, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wcjx-v2wj-xg87 and fix it if it is affected.\n\nWhat it is: GHSA-wcjx-v2wj-xg87 is a denial of service vulnerability in c2cciutils, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wcjx-v2wj-xg87 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- c2cciutils (PyPI): affected all versions; fixed in 1.1.66\n- c2cciutils (PyPI): affected all versions; fixed in 1.1.66\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wcjx-v2wj-xg87/ (Markdown: https://insights.sbomify.com/GHSA-wcjx-v2wj-xg87/index.md)","id":"GHSA-wcjx-v2wj-xg87","markdown":"https://insights.sbomify.com/GHSA-wcjx-v2wj-xg87/index.md","name":"GHSA-wcjx-v2wj-xg87","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python CI utility","requires_auth":"none","summary":"Attackers can cause denial of service in C2C CI utils via a vulnerable pyasn dependency, requiring library upgrades.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Pin vulnerable version of pyasn, see: See: https://github.com/advisories/GHSA-jr27-m4p2-rc6r","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"C2C CI utils is vulnerable to DoS via pyasn dependency (CVE-2026-30922)","id":"GHSA-wcjx-v2wj-xg87","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.1.66"],"introduced":["0"],"last_affected":[],"package":"c2cciutils","purl":null,"source":"GHSA-wcjx-v2wj-xg87"},{"ecosystem":"PyPI","fixed":["1.1.66"],"introduced":["0"],"last_affected":[],"package":"c2cciutils","purl":"pkg:pypi/c2cciutils","source":"GHSA-wcjx-v2wj-xg87"}],"products":null,"published":"2026-03-26","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in C2C CI utils via a vulnerable pyasn dependency, requiring library upgrades.","url":"https://insights.sbomify.com/GHSA-wcjx-v2wj-xg87/"}