{"answers":{"affected":"2 open source packages ship an affected version, including craftcms/cms.","exploited":"There is no known exploitation of GHSA-wf98-vxv9-jqfv in the wild and no public exploit code.","fix":"Upgrade craftcms/cms to 3.7.29 or later.","what":"GHSA-wf98-vxv9-jqfv is a cross-site scripting vulnerability in craftcms/cms, published on 5 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-wf98-vxv9-jqfv and fix it if it is affected.\n\nWhat it is: GHSA-wf98-vxv9-jqfv is a cross-site scripting vulnerability in craftcms/cms, published on 5 Apr 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-wf98-vxv9-jqfv in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- craftcms/cms (Packagist): affected all versions; fixed in 3.7.29\n- craftcms/cms (Packagist): affected all versions; fixed in 3.7.29\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wf98-vxv9-jqfv/ (Markdown: https://insights.sbomify.com/GHSA-wf98-vxv9-jqfv/index.md)","id":"GHSA-wf98-vxv9-jqfv","markdown":"https://insights.sbomify.com/GHSA-wf98-vxv9-jqfv/index.md","name":"GHSA-wf98-vxv9-jqfv","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS","requires_auth":"low_privilege","summary":"An XSS vulnerability in the Craft CMS Feeds widget allows attackers to inject malicious scripts via malformed feeds, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nUnder some circumstances, the Feeds widget on the dashboard could have an XSS vulnerability if a malformed feed was supplied.\n\n### Patches\n\nThis has been patched in Craft 3.7.29.\n\n### References\n\n* https://github.com/craftcms/cms/blob/develop/CHANGELOG.md#3729---2022-01-18\n\n### For more information\n\nIf you have any questions or comments about this advisory, email us at [support@craftcms.com](mailto:support@craftcms.com)\n\n----------\n\nCredits: https://github.com/noobpk","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"XSS Injection Vulnerability","id":"GHSA-wf98-vxv9-jqfv","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.7.29"],"introduced":["0"],"last_affected":[],"package":"craftcms/cms","purl":null,"source":"GHSA-wf98-vxv9-jqfv"},{"ecosystem":"Packagist","fixed":["3.7.29"],"introduced":["0"],"last_affected":[],"package":"craftcms/cms","purl":"pkg:composer/craftcms/cms","source":"GHSA-wf98-vxv9-jqfv"}],"products":null,"published":"2022-04-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XSS vulnerability in the Craft CMS Feeds widget allows attackers to inject malicious scripts via malformed feeds, potentially compromising user sessions.","url":"https://insights.sbomify.com/GHSA-wf98-vxv9-jqfv/"}