{"answers":{"affected":"2 open source packages ship an affected version, including ponse.","exploited":"There is no known exploitation of GHSA-wfhx-6pcm-7m55 in the wild and no public exploit code.","fix":"Upgrade ponse to 2.0.2 or later.","what":"GHSA-wfhx-6pcm-7m55 is a path traversal vulnerability in ponse, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wfhx-6pcm-7m55 and fix it if it is affected.\n\nWhat it is: GHSA-wfhx-6pcm-7m55 is a path traversal vulnerability in ponse, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wfhx-6pcm-7m55 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ponse (npm): affected all versions; fixed in 2.0.2\n- ponse (npm): affected all versions; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wfhx-6pcm-7m55/ (Markdown: https://insights.sbomify.com/GHSA-wfhx-6pcm-7m55/index.md)","id":"GHSA-wfhx-6pcm-7m55","markdown":"https://insights.sbomify.com/GHSA-wfhx-6pcm-7m55/index.md","name":"GHSA-wfhx-6pcm-7m55","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web server","requires_auth":"none","summary":"Attackers can read arbitrary server files outside the served directory due to unsanitized URL handling in the ponse library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `ponse` prior to 2.0.2 are vulnerable to Path Traversal. The package fails to sanitize URLs, allowing attackers to access server files outside of the served folder using relative paths.\n\n## Recommendation\n\nUpgrade to version 2.0.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Path Traversal in ponse","id":"GHSA-wfhx-6pcm-7m55","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"ponse","purl":null,"source":"GHSA-wfhx-6pcm-7m55"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"ponse","purl":"pkg:npm/ponse","source":"GHSA-wfhx-6pcm-7m55"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can read arbitrary server files outside the served directory due to unsanitized URL handling in the ponse library.","url":"https://insights.sbomify.com/GHSA-wfhx-6pcm-7m55/"}