# GHSA-wfm2-rq5g-f8v5: @account-kit/smart-contracts Allowlist Module Bypass Vulnerability

> Session keys can bypass allowlist configurations in Modular Account V2, allowing unauthorized actions if specific versions are used.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2025

## What is GHSA-wfm2-rq5g-f8v5?

GHSA-wfm2-rq5g-f8v5 is a vulnerability in @account-kit/smart-contracts, published on 29 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Summary
Allowlist module contains a bypass vulnerability

### Details
The logic for using an allowlist on a Modular Account V2 contained a bug that allowed session keys to bypass any allowlist configuration

### Action
If you are using @aa-sdk and/or @account-kit/smart-contracts between the versions of >=4.8.0 and <4.28.1, please upgrade to 4.28.2

## Which versions are affected by GHSA-wfm2-rq5g-f8v5?

2 open source packages ship an affected version, including @account-kit/smart-contracts.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@account-kit/smart-contracts` | npm | From 4.8.0 | 4.28.2 |
| `@account-kit/smart-contracts` | npm | From 4.8.0 | 4.28.2 |

## How do I fix GHSA-wfm2-rq5g-f8v5?

Upgrade @account-kit/smart-contracts to 4.28.2 or later.

## Is GHSA-wfm2-rq5g-f8v5 being exploited?

There is no known exploitation of GHSA-wfm2-rq5g-f8v5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-wfm2-rq5g-f8v5 and fix it if it is affected.

What it is: GHSA-wfm2-rq5g-f8v5 is a vulnerability in @account-kit/smart-contracts, published on 29 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-wfm2-rq5g-f8v5 in the wild and no public exploit code.

Affected packages and fixed versions:
- @account-kit/smart-contracts (npm): affected from 4.8.0; fixed in 4.28.2
- @account-kit/smart-contracts (npm): affected from 4.8.0; fixed in 4.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-wfm2-rq5g-f8v5/ (Markdown: https://insights.sbomify.com/GHSA-wfm2-rq5g-f8v5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-wfm2-rq5g-f8v5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-wfm2-rq5g-f8v5/
Summaries are generated and may contain mistakes; the official description above is the record.
