{"answers":{"affected":"2 open source packages ship an affected version, including sequelize.","exploited":"There is no known exploitation of GHSA-wfp9-vr4j-f49j in the wild and no public exploit code.","fix":"Upgrade sequelize to 4.12.0 or later.","what":"GHSA-wfp9-vr4j-f49j is a SQL injection vulnerability in sequelize, published on 4 Jun 2019. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wfp9-vr4j-f49j and fix it if it is affected.\n\nWhat it is: GHSA-wfp9-vr4j-f49j is a SQL injection vulnerability in sequelize, published on 4 Jun 2019. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wfp9-vr4j-f49j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sequelize (npm): affected all versions; fixed in 4.12.0\n- sequelize (npm): affected all versions; fixed in 4.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wfp9-vr4j-f49j/ (Markdown: https://insights.sbomify.com/GHSA-wfp9-vr4j-f49j/index.md)","id":"GHSA-wfp9-vr4j-f49j","markdown":"https://insights.sbomify.com/GHSA-wfp9-vr4j-f49j/index.md","name":"GHSA-wfp9-vr4j-f49j","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ORM library","requires_auth":"unknown","summary":"Attackers can inject NoSQL operators to alter database queries, potentially reading or modifying data, requiring an upgrade to the sequelize library.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `sequelize` prior to 4.12.0 are vulnerable to NoSQL Injection. Query operators such as `$gt` are not properly sanitized and may allow an attacker to alter data queries, leading to NoSQL Injection.\n\n## Recommendation\n\nUpgrade to version 4.12.0 or later","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"NoSQL Injection in sequelize","id":"GHSA-wfp9-vr4j-f49j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"sql_injection","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.12.0"],"introduced":["0"],"last_affected":[],"package":"sequelize","purl":null,"source":"GHSA-wfp9-vr4j-f49j"},{"ecosystem":"npm","fixed":["4.12.0"],"introduced":["0"],"last_affected":[],"package":"sequelize","purl":"pkg:npm/sequelize","source":"GHSA-wfp9-vr4j-f49j"}],"products":null,"published":"2019-06-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject NoSQL operators to alter database queries, potentially reading or modifying data, requiring an upgrade to the sequelize library.","url":"https://insights.sbomify.com/GHSA-wfp9-vr4j-f49j/"}