# GHSA-wfqx-gjrf-g28r: Crossplane: Signature verification TOCTOU allows installing unverified package content via mutable tag

> A race condition in Crossplane allows malicious registries to install unsigned packages by swapping content between signature verification and installation steps.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Also known as:** GO-2026-5709

## What is GHSA-wfqx-gjrf-g28r?

GHSA-wfqx-gjrf-g28r is a vulnerability in github.com/crossplane/crossplane, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

## Summary

Crossplane allows package signature verification to be configured via the `ImageConfig` mechanism. When enabled, the package manager uses cosign to verify that packages are correctly signed before pulling and installing them.

When a package is installed using a tag reference (e.g., a semantic version), a malicious OCI registry could serve a correctly signed image for verification, then subsequently serve an unsigned image for installation. This is possible because Crossplane resolves the tag reference separately for each step.

This vulnerability is relevant only for users who do all three of the following:

1. Configure signature verification for packages,
2. Install packages using tag references rather than digests, and
3. Install packages from registries they do not control.

## Mitigation

Installing packages by image digest rather than using tags avoids this issue.

## Fix

The package manager has been updated to resolve tag references once and use the resulting digest for both signature verification and image fetching. This ensures that Crossplane pulls the same content that had its signature verified. The fix has been applied to Crossplane's `main` branch and backported to the v2.3 and v2.2 release branches; it will be released in v2.3.3 and v2.2.3.

## Note on Fixed Versions

The Crossplane maintainers are *not* planning to backport the fix for this advisory to the 1.20 branch, for two reasons:

1. The advisory is relevant only when an alpha feature is enabled and configured, and has a reasonable mitigation that is already a security best practice.
2. Doing so would require a major refactor of package manager internals to match the refactor that shipped in Crossplane v2.2. Such a refactor would be an unnecessary risk given the policy that v1.20 receives only critical fixes and that this advisory affects only users of an alpha feature.

## Credits

This issue was reported, independently, by @bugbunny-research and @tonghuaroot.

## Which versions are affected by GHSA-wfqx-gjrf-g28r?

8 open source packages ship an affected version, including github.com/crossplane/crossplane/v2 and github.com/crossplane/crossplane.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/crossplane/crossplane/v2` | Go | All versions | 2.2.3 |
| `github.com/crossplane/crossplane/v2` | Go | All versions | 2.2.3 |
| `github.com/crossplane/crossplane/v2` | Go | From 2.3.0-rc.0 | None |
| `github.com/crossplane/crossplane/v2` | Go | From 2.3.0-rc.0 | 2.3.3 |
| `github.com/crossplane/crossplane/v2` | Go | From 2.3.0-rc.0 | 2.3.3 |
| `github.com/crossplane/crossplane` | Go | All versions | None |
| `github.com/crossplane/crossplane` | Go | All versions to 1.21.0-rc.0 | None |
| `github.com/crossplane/crossplane` | Go | All versions to 1.21.0-rc.0 | None |

## How do I fix GHSA-wfqx-gjrf-g28r?

Upgrade github.com/crossplane/crossplane/v2 to a fixed version for your release line: 2.2.3 or 2.3.3.

## Is GHSA-wfqx-gjrf-g28r being exploited?

There is no known exploitation of GHSA-wfqx-gjrf-g28r in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-wfqx-gjrf-g28r and fix it if it is affected.

What it is: GHSA-wfqx-gjrf-g28r is a vulnerability in github.com/crossplane/crossplane, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-wfqx-gjrf-g28r in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/crossplane/crossplane/v2 (Go): affected all versions; fixed in 2.2.3
- github.com/crossplane/crossplane/v2 (Go): affected all versions; fixed in 2.2.3
- github.com/crossplane/crossplane/v2 (Go): affected from 2.3.0-rc.0; no fix listed
- github.com/crossplane/crossplane/v2 (Go): affected from 2.3.0-rc.0; fixed in 2.3.3
- github.com/crossplane/crossplane/v2 (Go): affected from 2.3.0-rc.0; fixed in 2.3.3
- github.com/crossplane/crossplane (Go): affected all versions; no fix listed
- github.com/crossplane/crossplane (Go): affected all versions up to 1.21.0-rc.0; no fix listed
- github.com/crossplane/crossplane (Go): affected all versions up to 1.21.0-rc.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-wfqx-gjrf-g28r/ (Markdown: https://insights.sbomify.com/GHSA-wfqx-gjrf-g28r/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-wfqx-gjrf-g28r

---
From sbomify Insights: https://insights.sbomify.com/GHSA-wfqx-gjrf-g28r/
Summaries are generated and may contain mistakes; the official description above is the record.
