{"answers":{"affected":"2 open source packages ship an affected version, including polaris-website.","exploited":"There is no known exploitation of GHSA-whrh-9j4q-g7ph in the wild and no public exploit code.","fix":"Upgrade polaris-website to 1.1.1 or later.","what":"GHSA-whrh-9j4q-g7ph is a vulnerability in polaris-website, published on 5 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-whrh-9j4q-g7ph and fix it if it is affected.\n\nWhat it is: GHSA-whrh-9j4q-g7ph is a vulnerability in polaris-website, published on 5 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-whrh-9j4q-g7ph in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- polaris-website (npm): affected all versions; fixed in 1.1.1\n- polaris-website (npm): affected all versions; fixed in 1.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-whrh-9j4q-g7ph/ (Markdown: https://insights.sbomify.com/GHSA-whrh-9j4q-g7ph/index.md)","id":"GHSA-whrh-9j4q-g7ph","markdown":"https://insights.sbomify.com/GHSA-whrh-9j4q-g7ph/index.md","name":"GHSA-whrh-9j4q-g7ph","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Polaris website","requires_auth":"low_privilege","summary":"An attacker can modify user settings via CSRF if the victim visits a malicious site while logged in.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nCSRF vulnerability:\nIn some very specific circumstances, an attacker would be able to update your settings.\nBasically you would need to navigate to hackersite.com while logged into our panel. Then they could modify your settings. They couldn't check if it worked, nor could they read your settings.\n\n### Patches\nAs of v1.1.1 this has been patched by implementing the Double submit pattern using a cookie.\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [Polaris-React](https://github.com/polaris-rbx/polaris-react)\n* Email us at [hi@nezto.re](mailto:hi@nezto.re)\n* Join our discord (preferred): https://discord.gg/QevWabU","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"CSRF Vulnerability in polaris-website","id":"GHSA-whrh-9j4q-g7ph","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"polaris-website","purl":null,"source":"GHSA-whrh-9j4q-g7ph"},{"ecosystem":"npm","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"polaris-website","purl":"pkg:npm/polaris-website","source":"GHSA-whrh-9j4q-g7ph"}],"products":null,"published":"2020-08-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can modify user settings via CSRF if the victim visits a malicious site while logged in.","url":"https://insights.sbomify.com/GHSA-whrh-9j4q-g7ph/"}