{"answers":{"affected":"2 open source packages ship an affected version, including nextcloud-vue-collections.","exploited":"There is no known exploitation of GHSA-whv6-rj84-2vh2 in the wild and no public exploit code.","fix":"Upgrade nextcloud-vue-collections to 0.4.2 or later.","what":"GHSA-whv6-rj84-2vh2 is a cross-site scripting vulnerability in nextcloud-vue-collections, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-whv6-rj84-2vh2 and fix it if it is affected.\n\nWhat it is: GHSA-whv6-rj84-2vh2 is a cross-site scripting vulnerability in nextcloud-vue-collections, published on 4 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-whv6-rj84-2vh2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nextcloud-vue-collections (npm): affected all versions; fixed in 0.4.2\n- nextcloud-vue-collections (npm): affected all versions; fixed in 0.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-whv6-rj84-2vh2/ (Markdown: https://insights.sbomify.com/GHSA-whv6-rj84-2vh2/index.md)","id":"GHSA-whv6-rj84-2vh2","markdown":"https://insights.sbomify.com/GHSA-whv6-rj84-2vh2/index.md","name":"GHSA-whv6-rj84-2vh2","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue.js UI library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victims' browsers via insecure tooltip configuration in the nextcloud-vue-collections library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `nextcloud-vue-collections` prior to 0.4.2 are vulnerable to Cross-Site Scripting (XSS).  The `v-tooltip` component has an insecure `defaultHTML` configuration that allows arbitrary JavaScript to be injected in the tooltip of a collection item. This allows attackers to execute arbitrary code in a victim's browser.\n\n## Recommendation\n\nUpgrade to version 0.4.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in nextcloud-vue-collections","id":"GHSA-whv6-rj84-2vh2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.4.2"],"introduced":["0"],"last_affected":[],"package":"nextcloud-vue-collections","purl":null,"source":"GHSA-whv6-rj84-2vh2"},{"ecosystem":"npm","fixed":["0.4.2"],"introduced":["0"],"last_affected":[],"package":"nextcloud-vue-collections","purl":"pkg:npm/nextcloud-vue-collections","source":"GHSA-whv6-rj84-2vh2"}],"products":null,"published":"2020-09-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in victims' browsers via insecure tooltip configuration in the nextcloud-vue-collections library.","url":"https://insights.sbomify.com/GHSA-whv6-rj84-2vh2/"}