{"answers":{"affected":"2 open source packages ship an affected version, including nyholm/psr7.","exploited":"There is no known exploitation of GHSA-wjfc-pgfp-pv9c in the wild and no public exploit code.","fix":"Upgrade nyholm/psr7 to 1.6.1 or later.","what":"GHSA-wjfc-pgfp-pv9c is a vulnerability in nyholm/psr7, published on 21 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wjfc-pgfp-pv9c and fix it if it is affected.\n\nWhat it is: GHSA-wjfc-pgfp-pv9c is a vulnerability in nyholm/psr7, published on 21 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wjfc-pgfp-pv9c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nyholm/psr7 (Packagist): affected all versions; fixed in 1.6.1\n- nyholm/psr7 (Packagist): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wjfc-pgfp-pv9c/ (Markdown: https://insights.sbomify.com/GHSA-wjfc-pgfp-pv9c/index.md)","id":"GHSA-wjfc-pgfp-pv9c","markdown":"https://insights.sbomify.com/GHSA-wjfc-pgfp-pv9c/index.md","name":"GHSA-wjfc-pgfp-pv9c","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP PSR-7 library","requires_auth":"none","summary":"Attackers can inject newlines into HTTP headers via improper input validation in the nyholm/psr7 library, potentially causing request smuggling or header injection.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nImproper header parsing. An attacker could sneak in a newline (`\\n`) into both the header names and values. While the specification states that `\\r\\n\\r\\n` is used to terminate the header list, many servers in the wild will also accept `\\n\\n`.\n\n### Patches\n\nThe issue is patched in 1.6.1.\n\n### Workarounds\n\nThere are no known workarounds.\n\n### References\n\n* https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Improper Input Validation in nyholm/psr7","id":"GHSA-wjfc-pgfp-pv9c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"nyholm/psr7","purl":null,"source":"GHSA-wjfc-pgfp-pv9c"},{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"nyholm/psr7","purl":"pkg:composer/nyholm/psr7","source":"GHSA-wjfc-pgfp-pv9c"}],"products":null,"published":"2023-04-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject newlines into HTTP headers via improper input validation in the nyholm/psr7 library, potentially causing request smuggling or header injection.","url":"https://insights.sbomify.com/GHSA-wjfc-pgfp-pv9c/"}