{"answers":{"affected":"2 open source packages ship an affected version, including ckb.","exploited":"There is no known exploitation of GHSA-wjxc-pjx9-4wvm in the wild and no public exploit code.","fix":"Upgrade ckb to 0.34.2 or later.","what":"GHSA-wjxc-pjx9-4wvm is a denial of service vulnerability in ckb, published on 3 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wjxc-pjx9-4wvm and fix it if it is affected.\n\nWhat it is: GHSA-wjxc-pjx9-4wvm is a denial of service vulnerability in ckb, published on 3 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wjxc-pjx9-4wvm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckb (crates.io): affected all versions; fixed in 0.34.2\n- ckb (crates.io): affected all versions; fixed in 0.34.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wjxc-pjx9-4wvm/ (Markdown: https://insights.sbomify.com/GHSA-wjxc-pjx9-4wvm/index.md)","id":"GHSA-wjxc-pjx9-4wvm","markdown":"https://insights.sbomify.com/GHSA-wjxc-pjx9-4wvm/index.md","name":"GHSA-wjxc-pjx9-4wvm","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Nervos CKB node","requires_auth":"none","summary":"Remote attackers can crash the Nervos CKB node by sending malformed P2P messages, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nCKB process will panic when received malformed p2p message because of snappy, which is used to compress network messages\n\n### References\nhttps://github.com/BurntSushi/rust-snappy/issues/29","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Nervos CKB Panic on malformed input","id":"GHSA-wjxc-pjx9-4wvm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.34.2"],"introduced":["0"],"last_affected":[],"package":"ckb","purl":null,"source":"GHSA-wjxc-pjx9-4wvm"},{"ecosystem":"crates.io","fixed":["0.34.2"],"introduced":["0"],"last_affected":[],"package":"ckb","purl":"pkg:cargo/ckb","source":"GHSA-wjxc-pjx9-4wvm"}],"products":null,"published":"2024-02-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote attackers can crash the Nervos CKB node by sending malformed P2P messages, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-wjxc-pjx9-4wvm/"}