{"answers":{"affected":"2 open source packages ship an affected version, including superstatic.","exploited":"There is no known exploitation of GHSA-wm77-q74p-5763 in the wild and no public exploit code.","fix":"Upgrade superstatic to 5.0.2 or later.","what":"GHSA-wm77-q74p-5763 is a path traversal vulnerability in superstatic, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wm77-q74p-5763 and fix it if it is affected.\n\nWhat it is: GHSA-wm77-q74p-5763 is a path traversal vulnerability in superstatic, published on 27 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wm77-q74p-5763 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- superstatic (npm): affected all versions; fixed in 5.0.2\n- superstatic (npm): affected all versions; fixed in 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wm77-q74p-5763/ (Markdown: https://insights.sbomify.com/GHSA-wm77-q74p-5763/index.md)","id":"GHSA-wm77-q74p-5763","markdown":"https://insights.sbomify.com/GHSA-wm77-q74p-5763/index.md","name":"GHSA-wm77-q74p-5763","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js static server","requires_auth":"none","summary":"Attackers can read arbitrary files via path traversal in superstatic, particularly on Windows or specific Node.js versions.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected of `superstatic` are vulnerable to path traversal when used on Windows. \n\nAdditionally, it is vulnerable to path traversal on other platforms combined with certain Node.js versions which erroneously normalize `\\\\` to `/` in paths on all platforms (a known example being Node.js v9.9.0).\n\n## Recommendation\n\nUpdate to version 5.0.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Path Traversal in superstatic","id":"GHSA-wm77-q74p-5763","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"superstatic","purl":null,"source":"GHSA-wm77-q74p-5763"},{"ecosystem":"npm","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"superstatic","purl":"pkg:npm/superstatic","source":"GHSA-wm77-q74p-5763"}],"products":null,"published":"2018-07-27","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can read arbitrary files via path traversal in superstatic, particularly on Windows or specific Node.js versions.","url":"https://insights.sbomify.com/GHSA-wm77-q74p-5763/"}