{"answers":{"affected":"3 open source packages ship an affected version, including github.com/netlify/gotrue.","exploited":"There is no known exploitation of GHSA-wpfr-6297-9v57 in the wild and no public exploit code.","fix":"Upgrade github.com/netlify/gotrue to 1.0.1 or later.","what":"GHSA-wpfr-6297-9v57 is a vulnerability in github.com/netlify/gotrue, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wpfr-6297-9v57 and fix it if it is affected.\n\nWhat it is: GHSA-wpfr-6297-9v57 is a vulnerability in github.com/netlify/gotrue, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wpfr-6297-9v57 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/netlify/gotrue (Go): affected all versions; fixed in 1.0.1\n- github.com/netlify/gotrue (Go): affected all versions; fixed in 1.0.1\n- github.com/netlify/gotrue (Go): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wpfr-6297-9v57/ (Markdown: https://insights.sbomify.com/GHSA-wpfr-6297-9v57/index.md)","id":"GHSA-wpfr-6297-9v57","markdown":"https://insights.sbomify.com/GHSA-wpfr-6297-9v57/index.md","name":"GHSA-wpfr-6297-9v57","record":{"aliases":["GO-2022-0365"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Go authentication service","requires_auth":"none","summary":"GoTrue creates user objects with invalid provider metadata, potentially allowing security bypasses if that metadata is used for authorization decisions.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n_What kind of vulnerability is it? Who is impacted?_\n\nUnder certain circumstances a valid user object would have been created with invalid provider metadata.\n\nThis vulnerability affects everyone running an instance of GoTrue as a service. We advise you to update especially if you are using the provider metadata from the user object to secure other resources.\n\n### Patches\n_Has the problem been patched? What versions should users upgrade to?_\n\nA patch is available with the release of version [1.0.1 on Github](https://github.com/netlify/gotrue/releases/tag/v1.0.1).\n\n### Workarounds\n_Is there a way for users to fix or remediate the vulnerability without upgrading?_\n\nIf you don't rely on the provider metadata in the user object, you might not be affected. We still strongly recommend upgrading.\n\n### References\n_Are there any links users can visit to find out more?_\n\nThis problem was initially found and reported by the team at Supabase: https://github.com/supabase/gotrue/security/advisories/GHSA-5hvv-9cqv-894r. We want to thank them for the cooperation around this report.\n\nIn contrast to their advisory, we decided to set the severity to \"Moderate\" since the provider metadata is not an inherent security feature of this GoTrue codebase or the Netlify ecosystem.\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Email us at [security@netlify.com](mailto:security@netlify.com)","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"User object created with invalid provider data in GoTrue","id":"GHSA-wpfr-6297-9v57","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"business_logic","year":"2022"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"github.com/netlify/gotrue","purl":null,"source":"GHSA-wpfr-6297-9v57"},{"ecosystem":"Go","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"github.com/netlify/gotrue","purl":"pkg:golang/github.com/netlify/gotrue","source":"GHSA-wpfr-6297-9v57"},{"ecosystem":"Go","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"github.com/netlify/gotrue","purl":"pkg:golang/github.com/netlify/gotrue","source":"GO-2022-0365"}],"products":null,"published":"2022-02-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"GoTrue creates user objects with invalid provider metadata, potentially allowing security bypasses if that metadata is used for authorization decisions.","url":"https://insights.sbomify.com/GHSA-wpfr-6297-9v57/"}