# GHSA-wq9x-qwcq-mmgf: Diesel vulnerable to Binary Protocol Misinterpretation caused by Truncating or Overflowing Casts

> An integer overflow in Diesel's binary protocol handling allows attackers to smuggle SQL queries, potentially leading to code execution or data modification.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2024
- **Also known as:** RUSTSEC-2024-0365

## What is GHSA-wq9x-qwcq-mmgf?

GHSA-wq9x-qwcq-mmgf is a vulnerability in diesel, published on 23 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The following presentation at this year's DEF CON was brought to our attention on the Diesel Gitter Channel:

> SQL Injection isn't Dead: Smuggling Queries at the Protocol Level  
> <http://web.archive.org/web/20240812130923/https://media.defcon.org/DEF%20CON%2032/DEF%20CON%2032%20presentations/DEF%20CON%2032%20-%20Paul%20Gerste%20-%20SQL%20Injection%20Isn't%20Dead%20Smuggling%20Queries%20at%20the%20Protocol%20Level.pdf>  
> (Archive link for posterity.)
Essentially, encoding a value larger than 4GiB can cause the length prefix in the protocol to overflow, 
causing the server to interpret the rest of the string as binary protocol commands or other data.

It appears Diesel _does_ perform truncating casts in a way that could be problematic, 
for example: <https://github.com/diesel-rs/diesel/blob/ae82c4a5a133db65612b7436356f549bfecda1c7/diesel/src/pg/connection/stmt/mod.rs#L36>

This code has existed essentially since the beginning, 
so it is reasonable to assume that all published versions `<= 2.2.2` are affected.

## Mitigation

The prefered migration to the outlined problem is to update to a Diesel version newer than 2.2.2, which includes 
fixes for the problem. 

As always, you should make sure your application is validating untrustworthy user input. 
Reject any input over 4 GiB, or any input that could _encode_ to a string longer than 4 GiB. 
Dynamically built queries are also potentially problematic if it pushes the message size over this 4 GiB bound.

For web application backends, consider adding some middleware that limits the size of request bodies by default.

## Resolution

Diesel now uses `#[deny]` directives for the following Clippy lints:

* [`cast_possible_truncation`](https://rust-lang.github.io/rust-clippy/master/#/cast_possible_truncation)
* [`cast_possible_wrap`](https://rust-lang.github.io/rust-clippy/master/#/cast_possible_wrap)
* [`cast_sign_loss`](https://rust-lang.github.io/rust-clippy/master/#/cast_sign_loss)

to prevent casts that will lead to precision loss or other trunctations. Additionally we performed an 
audit of the relevant code.

A fix is included in the `2.2.3` release.

## Which versions are affected by GHSA-wq9x-qwcq-mmgf?

3 open source packages ship an affected version, including diesel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `diesel` | crates.io | All versions | 2.2.3 |
| `diesel` | crates.io | All versions | 2.2.3 |
| `diesel` | crates.io | From 0.0.0-0 | 2.2.3 |

## How do I fix GHSA-wq9x-qwcq-mmgf?

Upgrade diesel to 2.2.3 or later.

## Is GHSA-wq9x-qwcq-mmgf being exploited?

There is no known exploitation of GHSA-wq9x-qwcq-mmgf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-wq9x-qwcq-mmgf and fix it if it is affected.

What it is: GHSA-wq9x-qwcq-mmgf is a vulnerability in diesel, published on 23 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-wq9x-qwcq-mmgf in the wild and no public exploit code.

Affected packages and fixed versions:
- diesel (crates.io): affected all versions; fixed in 2.2.3
- diesel (crates.io): affected all versions; fixed in 2.2.3
- diesel (crates.io): affected from 0.0.0-0; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-wq9x-qwcq-mmgf/ (Markdown: https://insights.sbomify.com/GHSA-wq9x-qwcq-mmgf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-wq9x-qwcq-mmgf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-wq9x-qwcq-mmgf/
Summaries are generated and may contain mistakes; the official description above is the record.
