GHSA-wqm8-jx8r-8rcq Cross-site scripting vulnerabilities in old version of bundled TinyMCE
Cross-site scripting in bundled TinyMCE allows arbitrary JavaScript execution via crafted content, impacting Silverstripe CMS users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-wqm8-jx8r-8rcq?
GHSA-wqm8-jx8r-8rcq is a cross-site scripting vulnerability in silverstripe/admin, published on 26 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An old version of TinyMCE include an XSS vulnerability, which was patched in a later version. This was described by TinyMCE:
> A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower.
We reviewed the potential impact of this vulnerability within the context of Silverstripe CMS. We concluded this is a medium impact vulnerability given how TinyMCE is used by Silverstripe CMS.
Reported by: Developers at ACC
Which versions are affected by GHSA-wqm8-jx8r-8rcq?
2 open source packages ship an affected version, including silverstripe/admin.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/admin Packagist | All versions | 1.12.7 |
silverstripe/admin Packagist | All versions | 1.12.7 |
How do I fix GHSA-wqm8-jx8r-8rcq?
Upgrade silverstripe/admin to 1.12.7 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is GHSA-wqm8-jx8r-8rcq being exploited?
There is no known exploitation of GHSA-wqm8-jx8r-8rcq in the wild and no public exploit code.