{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/admin.","exploited":"There is no known exploitation of GHSA-wqm8-jx8r-8rcq in the wild and no public exploit code.","fix":"Upgrade silverstripe/admin to 1.12.7 or later.","what":"GHSA-wqm8-jx8r-8rcq is a cross-site scripting vulnerability in silverstripe/admin, published on 26 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-wqm8-jx8r-8rcq and fix it if it is affected.\n\nWhat it is: GHSA-wqm8-jx8r-8rcq is a cross-site scripting vulnerability in silverstripe/admin, published on 26 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-wqm8-jx8r-8rcq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/admin (Packagist): affected all versions; fixed in 1.12.7\n- silverstripe/admin (Packagist): affected all versions; fixed in 1.12.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wqm8-jx8r-8rcq/ (Markdown: https://insights.sbomify.com/GHSA-wqm8-jx8r-8rcq/index.md)","id":"GHSA-wqm8-jx8r-8rcq","markdown":"https://insights.sbomify.com/GHSA-wqm8-jx8r-8rcq/index.md","name":"GHSA-wqm8-jx8r-8rcq","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Silverstripe CMS","requires_auth":"low_privilege","summary":"Cross-site scripting in bundled TinyMCE allows arbitrary JavaScript execution via crafted content, impacting Silverstripe CMS users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"An old version of TinyMCE include an XSS vulnerability, which was patched in a later version. This was described by TinyMCE:\n\n\u003e A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower.\n\nWe reviewed the potential impact of this vulnerability within the context of Silverstripe CMS. We concluded this is a medium impact vulnerability given how TinyMCE is used by Silverstripe CMS.\n\nReported by: Developers at ACC","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-site scripting vulnerabilities in old version of bundled TinyMCE","id":"GHSA-wqm8-jx8r-8rcq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.12.7"],"introduced":["0"],"last_affected":[],"package":"silverstripe/admin","purl":null,"source":"GHSA-wqm8-jx8r-8rcq"},{"ecosystem":"Packagist","fixed":["1.12.7"],"introduced":["0"],"last_affected":[],"package":"silverstripe/admin","purl":"pkg:composer/silverstripe/admin","source":"GHSA-wqm8-jx8r-8rcq"}],"products":null,"published":"2023-04-26","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Cross-site scripting in bundled TinyMCE allows arbitrary JavaScript execution via crafted content, impacting Silverstripe CMS users.","url":"https://insights.sbomify.com/GHSA-wqm8-jx8r-8rcq/"}