# GHSA-wqm8-jx8r-8rcq: Cross-site scripting vulnerabilities in old version of bundled TinyMCE

> Cross-site scripting in bundled TinyMCE allows arbitrary JavaScript execution via crafted content, impacting Silverstripe CMS users.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Apr 2023

## What is GHSA-wqm8-jx8r-8rcq?

GHSA-wqm8-jx8r-8rcq is a cross-site scripting vulnerability in silverstripe/admin, published on 26 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An old version of TinyMCE include an XSS vulnerability, which was patched in a later version. This was described by TinyMCE:

> A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower.

We reviewed the potential impact of this vulnerability within the context of Silverstripe CMS. We concluded this is a medium impact vulnerability given how TinyMCE is used by Silverstripe CMS.

Reported by: Developers at ACC

## Which versions are affected by GHSA-wqm8-jx8r-8rcq?

2 open source packages ship an affected version, including silverstripe/admin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/admin` | Packagist | All versions | 1.12.7 |
| `silverstripe/admin` | Packagist | All versions | 1.12.7 |

## How do I fix GHSA-wqm8-jx8r-8rcq?

Upgrade silverstripe/admin to 1.12.7 or later.

## Is GHSA-wqm8-jx8r-8rcq being exploited?

There is no known exploitation of GHSA-wqm8-jx8r-8rcq in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-wqm8-jx8r-8rcq and fix it if it is affected.

What it is: GHSA-wqm8-jx8r-8rcq is a cross-site scripting vulnerability in silverstripe/admin, published on 26 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-wqm8-jx8r-8rcq in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/admin (Packagist): affected all versions; fixed in 1.12.7
- silverstripe/admin (Packagist): affected all versions; fixed in 1.12.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-wqm8-jx8r-8rcq/ (Markdown: https://insights.sbomify.com/GHSA-wqm8-jx8r-8rcq/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-wqm8-jx8r-8rcq

---
From sbomify Insights: https://insights.sbomify.com/GHSA-wqm8-jx8r-8rcq/
Summaries are generated and may contain mistakes; the official description above is the record.
