{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/autoupgrade.","exploited":"There is no known exploitation of GHSA-wqq8-mqj9-697f in the wild and no public exploit code.","fix":"Upgrade prestashop/autoupgrade to 4.10.1 or later.","what":"GHSA-wqq8-mqj9-697f is a code injection vulnerability in prestashop/autoupgrade, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wqq8-mqj9-697f and fix it if it is affected.\n\nWhat it is: GHSA-wqq8-mqj9-697f is a code injection vulnerability in prestashop/autoupgrade, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wqq8-mqj9-697f in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/autoupgrade (Packagist): affected from 4.0.0; fixed in 4.10.1\n- prestashop/autoupgrade (Packagist): affected from 4.0.0; fixed in 4.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wqq8-mqj9-697f/ (Markdown: https://insights.sbomify.com/GHSA-wqq8-mqj9-697f/index.md)","id":"GHSA-wqq8-mqj9-697f","markdown":"https://insights.sbomify.com/GHSA-wqq8-mqj9-697f/index.md","name":"GHSA-wqq8-mqj9-697f","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop autoupgrade module","requires_auth":"none","summary":"Attackers can execute arbitrary code on PrestaShop servers via vulnerable PHPUnit scripts included in autoupgrade module archives.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nWe have identified that some autoupgrade module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE.\n\nThis vulnerability impacts\n- phpunit before 4.8.28 and 5.x before 5.6.3 as reported in [CVE-2017-9841](https://nvd.nist.gov/vuln/detail/CVE-2017-9841)\n- phpunit \u003e= 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers)\n\nYou can read PrestaShop official statement about this vulnerability [here](https://build.prestashop.com/news/critical-security-vulnerability-in-prestashop-modules/).\n\n### Patches\n\nIn the [security patch](https://github.com/PrestaShop/autoupgrade/releases/tag/v4.10.1), we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading.\n\n### Workarounds\nUsers can also simply remove the unwanted vendor/phpunit folder.\n\n### References\nhttps://nvd.nist.gov/vuln/detail/CVE-2017-9841\n\n### For more information\nIf you have any questions or comments about this advisory, email us at security@prestashop.com","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"PrestaShop autoupgrade module ZIP archives were vulnerable from CVE-2017-9841","id":"GHSA-wqq8-mqj9-697f","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.10.1"],"introduced":["4.0.0"],"last_affected":[],"package":"prestashop/autoupgrade","purl":null,"source":"GHSA-wqq8-mqj9-697f"},{"ecosystem":"Packagist","fixed":["4.10.1"],"introduced":["4.0.0"],"last_affected":[],"package":"prestashop/autoupgrade","purl":"pkg:composer/prestashop/autoupgrade","source":"GHSA-wqq8-mqj9-697f"}],"products":null,"published":"2020-01-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code on PrestaShop servers via vulnerable PHPUnit scripts included in autoupgrade module archives.","url":"https://insights.sbomify.com/GHSA-wqq8-mqj9-697f/"}