# GHSA-wrw9-m778-g6mc: Memory Exposure in bl

> An attacker can read uninitialized memory by triggering buffer appends with numeric inputs in the bl library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2019

## What is GHSA-wrw9-m778-g6mc?

GHSA-wrw9-m778-g6mc is a vulnerability in bl, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of `bl` before 0.9.5 and 1.0.1 are vulnerable to memory exposure.

`bl.append(number)` in the affected `bl` versions passes a number to Buffer constructor, appending a chunk of uninitialized memory

## Recommendation

Update to version 0.9.5, 1.0.1 or later.

## Which versions are affected by GHSA-wrw9-m778-g6mc?

4 open source packages ship an affected version, including bl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bl` | npm | All versions | 0.9.5 |
| `bl` | npm | All versions | 0.9.5 |
| `bl` | npm | From 1.0.0 | 1.0.1 |
| `bl` | npm | From 1.0.0 | 1.0.1 |

## How do I fix GHSA-wrw9-m778-g6mc?

Upgrade bl to a fixed version for your release line: 0.9.5 or 1.0.1.

## Is GHSA-wrw9-m778-g6mc being exploited?

There is no known exploitation of GHSA-wrw9-m778-g6mc in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-wrw9-m778-g6mc and fix it if it is affected.

What it is: GHSA-wrw9-m778-g6mc is a vulnerability in bl, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-wrw9-m778-g6mc in the wild and no public exploit code.

Affected packages and fixed versions:
- bl (npm): affected all versions; fixed in 0.9.5
- bl (npm): affected all versions; fixed in 0.9.5
- bl (npm): affected from 1.0.0; fixed in 1.0.1
- bl (npm): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-wrw9-m778-g6mc/ (Markdown: https://insights.sbomify.com/GHSA-wrw9-m778-g6mc/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-wrw9-m778-g6mc

---
From sbomify Insights: https://insights.sbomify.com/GHSA-wrw9-m778-g6mc/
Summaries are generated and may contain mistakes; the official description above is the record.
