{"answers":{"affected":"3 open source packages ship an affected version, including github.com/fkie-cad/yapscan.","exploited":"There is no known exploitation of GHSA-wxwq-525w-hcqx in the wild and no public exploit code.","fix":"Upgrade github.com/fkie-cad/yapscan to 0.19.2 or later.","what":"GHSA-wxwq-525w-hcqx is a denial of service vulnerability in github.com/fkie-cad/yapscan, published on 3 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wxwq-525w-hcqx and fix it if it is affected.\n\nWhat it is: GHSA-wxwq-525w-hcqx is a denial of service vulnerability in github.com/fkie-cad/yapscan, published on 3 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wxwq-525w-hcqx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.2\n- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.2\n- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wxwq-525w-hcqx/ (Markdown: https://insights.sbomify.com/GHSA-wxwq-525w-hcqx/index.md)","id":"GHSA-wxwq-525w-hcqx","markdown":"https://insights.sbomify.com/GHSA-wxwq-525w-hcqx/index.md","name":"GHSA-wxwq-525w-hcqx","record":{"aliases":["GO-2023-1607"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Go report server library","requires_auth":"none","summary":"Attackers can cause a Denial of Service in Yapscan's report server if enabled, requiring an upgrade to the patched version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nIf you use the report server, it may be vulnerable to a Denial of Service attack.\n\n### Patches\n\nHas been patched in v0.19.2.\n\n### References\n\nThe vulnerability was inherited by the following upstream vulnerabilites\n\n- [golang.org/x/text \u003c v0.3.7](https://github.com/advisories/GHSA-ppp9-7jff-5vj2)\n- [golang.org/x/net \u003c 0.0.0-20220906165146-f3363e06e74c](https://github.com/advisories/GHSA-69cg-p879-7622)","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Yapscan Denial of Service vulnerability in report server","id":"GHSA-wxwq-525w-hcqx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.19.2"],"introduced":["0.18.0"],"last_affected":[],"package":"github.com/fkie-cad/yapscan","purl":null,"source":"GHSA-wxwq-525w-hcqx"},{"ecosystem":"Go","fixed":["0.19.2"],"introduced":["0.18.0"],"last_affected":[],"package":"github.com/fkie-cad/yapscan","purl":"pkg:golang/github.com/fkie-cad/yapscan","source":"GHSA-wxwq-525w-hcqx"},{"ecosystem":"Go","fixed":["0.19.2"],"introduced":["0.18.0"],"last_affected":[],"package":"github.com/fkie-cad/yapscan","purl":"pkg:golang/github.com/fkie-cad/yapscan","source":"GO-2023-1607"}],"products":null,"published":"2023-03-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause a Denial of Service in Yapscan's report server if enabled, requiring an upgrade to the patched version.","url":"https://insights.sbomify.com/GHSA-wxwq-525w-hcqx/"}