# GHSA-wxwq-525w-hcqx: Yapscan Denial of Service vulnerability in report server

> Attackers can cause a Denial of Service in Yapscan's report server if enabled, requiring an upgrade to the patched version.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2023
- **Also known as:** GO-2023-1607

## What is GHSA-wxwq-525w-hcqx?

GHSA-wxwq-525w-hcqx is a denial of service vulnerability in github.com/fkie-cad/yapscan, published on 3 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact

If you use the report server, it may be vulnerable to a Denial of Service attack.

### Patches

Has been patched in v0.19.2.

### References

The vulnerability was inherited by the following upstream vulnerabilites

- [golang.org/x/text < v0.3.7](https://github.com/advisories/GHSA-ppp9-7jff-5vj2)
- [golang.org/x/net < 0.0.0-20220906165146-f3363e06e74c](https://github.com/advisories/GHSA-69cg-p879-7622)

## Which versions are affected by GHSA-wxwq-525w-hcqx?

3 open source packages ship an affected version, including github.com/fkie-cad/yapscan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fkie-cad/yapscan` | Go | From 0.18.0 | 0.19.2 |
| `github.com/fkie-cad/yapscan` | Go | From 0.18.0 | 0.19.2 |
| `github.com/fkie-cad/yapscan` | Go | From 0.18.0 | 0.19.2 |

## How do I fix GHSA-wxwq-525w-hcqx?

Upgrade github.com/fkie-cad/yapscan to 0.19.2 or later.

## Is GHSA-wxwq-525w-hcqx being exploited?

There is no known exploitation of GHSA-wxwq-525w-hcqx in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-wxwq-525w-hcqx and fix it if it is affected.

What it is: GHSA-wxwq-525w-hcqx is a denial of service vulnerability in github.com/fkie-cad/yapscan, published on 3 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-wxwq-525w-hcqx in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.2
- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.2
- github.com/fkie-cad/yapscan (Go): affected from 0.18.0; fixed in 0.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-wxwq-525w-hcqx/ (Markdown: https://insights.sbomify.com/GHSA-wxwq-525w-hcqx/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-wxwq-525w-hcqx

---
From sbomify Insights: https://insights.sbomify.com/GHSA-wxwq-525w-hcqx/
Summaries are generated and may contain mistakes; the official description above is the record.
