GHSA-wxxw-5gq6-j2g5 contao/core Insufficient input validation allows for code injection and remote execution

Not scored Published

Attackers can execute arbitrary code or cause denial of service by exploiting insufficient input validation in Contao CMS.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-wxxw-5gq6-j2g5?

GHSA-wxxw-5gq6-j2g5 is a code injection vulnerability in contao/core, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.

Which versions are affected by GHSA-wxxw-5gq6-j2g5?

4 open source packages ship an affected version, including contao/core.

PackageAffectedFixed in
contao/core PackagistFrom 2.0.02.11.17
contao/core PackagistFrom 2.0.02.11.17
contao/core PackagistFrom 3.0.03.2.9
contao/core PackagistFrom 3.0.03.2.9

How do I fix GHSA-wxxw-5gq6-j2g5?

Upgrade contao/core to a fixed version for your release line: 2.11.17 or 3.2.9.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is GHSA-wxxw-5gq6-j2g5 being exploited?

There is no known exploitation of GHSA-wxxw-5gq6-j2g5 in the wild and no public exploit code.

Sources

Is GHSA-wxxw-5gq6-j2g5 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free