{"answers":{"affected":"4 open source packages ship an affected version, including contao/core.","exploited":"There is no known exploitation of GHSA-wxxw-5gq6-j2g5 in the wild and no public exploit code.","fix":"Upgrade contao/core to a fixed version for your release line: 2.11.17 or 3.2.9.","what":"GHSA-wxxw-5gq6-j2g5 is a code injection vulnerability in contao/core, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-wxxw-5gq6-j2g5 and fix it if it is affected.\n\nWhat it is: GHSA-wxxw-5gq6-j2g5 is a code injection vulnerability in contao/core, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-wxxw-5gq6-j2g5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- contao/core (Packagist): affected from 2.0.0; fixed in 2.11.17\n- contao/core (Packagist): affected from 2.0.0; fixed in 2.11.17\n- contao/core (Packagist): affected from 3.0.0; fixed in 3.2.9\n- contao/core (Packagist): affected from 3.0.0; fixed in 3.2.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-wxxw-5gq6-j2g5/ (Markdown: https://insights.sbomify.com/GHSA-wxxw-5gq6-j2g5/index.md)","id":"GHSA-wxxw-5gq6-j2g5","markdown":"https://insights.sbomify.com/GHSA-wxxw-5gq6-j2g5/index.md","name":"GHSA-wxxw-5gq6-j2g5","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Contao CMS","requires_auth":"none","summary":"Attackers can execute arbitrary code or cause denial of service by exploiting insufficient input validation in Contao CMS.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"contao/core Insufficient input validation allows for code injection and remote execution","id":"GHSA-wxxw-5gq6-j2g5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.11.17"],"introduced":["2.0.0"],"last_affected":[],"package":"contao/core","purl":null,"source":"GHSA-wxxw-5gq6-j2g5"},{"ecosystem":"Packagist","fixed":["2.11.17"],"introduced":["2.0.0"],"last_affected":[],"package":"contao/core","purl":"pkg:composer/contao/core","source":"GHSA-wxxw-5gq6-j2g5"},{"ecosystem":"Packagist","fixed":["3.2.9"],"introduced":["3.0.0"],"last_affected":[],"package":"contao/core","purl":null,"source":"GHSA-wxxw-5gq6-j2g5"},{"ecosystem":"Packagist","fixed":["3.2.9"],"introduced":["3.0.0"],"last_affected":[],"package":"contao/core","purl":"pkg:composer/contao/core","source":"GHSA-wxxw-5gq6-j2g5"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code or cause denial of service by exploiting insufficient input validation in Contao CMS.","url":"https://insights.sbomify.com/GHSA-wxxw-5gq6-j2g5/"}