# GHSA-x477-fq37-q5wr: Initial debug-host handler implementation could leak information and facilitate denial of service

> Enabling the debug-host feature in Fortio Proxy exposes host information and allows denial of service attacks.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2023
- **Also known as:** GO-2023-1524

## What is GHSA-x477-fq37-q5wr?

GHSA-x477-fq37-q5wr is a vulnerability in fortio.org/proxy, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact
version 1.5.0 and 1.6.0 when using the new `debug-host` feature could expose unnecessary information about the host

### Patches
Use 1.6.1 or newer

### Workarounds
Downgrade to 1.4.0 or set `debug-host` to empty

### References
https://github.com/fortio/proxy/pull/38

Q&A https://github.com/fortio/proxy/discussions

## Which versions are affected by GHSA-x477-fq37-q5wr?

3 open source packages ship an affected version, including fortio.org/proxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fortio.org/proxy` | Go | From 1.5.0 | 1.6.1 |
| `fortio.org/proxy` | Go | From 1.5.0 | 1.6.1 |
| `fortio.org/proxy` | Go | From 1.5.0 | 1.6.1 |

## How do I fix GHSA-x477-fq37-q5wr?

Upgrade fortio.org/proxy to 1.6.1 or later.

## Is GHSA-x477-fq37-q5wr being exploited?

There is no known exploitation of GHSA-x477-fq37-q5wr in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-x477-fq37-q5wr and fix it if it is affected.

What it is: GHSA-x477-fq37-q5wr is a vulnerability in fortio.org/proxy, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-x477-fq37-q5wr in the wild and no public exploit code.

Affected packages and fixed versions:
- fortio.org/proxy (Go): affected from 1.5.0; fixed in 1.6.1
- fortio.org/proxy (Go): affected from 1.5.0; fixed in 1.6.1
- fortio.org/proxy (Go): affected from 1.5.0; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-x477-fq37-q5wr/ (Markdown: https://insights.sbomify.com/GHSA-x477-fq37-q5wr/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-x477-fq37-q5wr

---
From sbomify Insights: https://insights.sbomify.com/GHSA-x477-fq37-q5wr/
Summaries are generated and may contain mistakes; the official description above is the record.
