GHSA-x48m-gp6r-gp4v Malicious Package in rate-map

Not scored Published

Attackers can execute malicious code and modify dependencies via a compromised npm package, requiring developers to upgrade immediately.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-x48m-gp6r-gp4v?

GHSA-x48m-gp6r-gp4v is a vulnerability in rate-map, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Version 1.0.3 of rate-map contains malicious code. The malware breaks functionality of the purescript-installer package by rewriting code of the dl-tar dependency.

Recommendation

Upgrade to version 1.0.5 or later. There is no indication of further compromise.

Which versions are affected by GHSA-x48m-gp6r-gp4v?

2 open source packages ship an affected version, including rate-map.

PackageAffectedFixed in
rate-map npmFrom 1.0.31.0.5
rate-map npmFrom 1.0.31.0.5

How do I fix GHSA-x48m-gp6r-gp4v?

Upgrade rate-map to 1.0.5 or later.

Is GHSA-x48m-gp6r-gp4v being exploited?

There is no known exploitation of GHSA-x48m-gp6r-gp4v in the wild and no public exploit code.

Sources

Is GHSA-x48m-gp6r-gp4v in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free