{"answers":{"affected":"2 open source packages ship an affected version, including rate-map.","exploited":"There is no known exploitation of GHSA-x48m-gp6r-gp4v in the wild and no public exploit code.","fix":"Upgrade rate-map to 1.0.5 or later.","what":"GHSA-x48m-gp6r-gp4v is a vulnerability in rate-map, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-x48m-gp6r-gp4v and fix it if it is affected.\n\nWhat it is: GHSA-x48m-gp6r-gp4v is a vulnerability in rate-map, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-x48m-gp6r-gp4v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rate-map (npm): affected from 1.0.3; fixed in 1.0.5\n- rate-map (npm): affected from 1.0.3; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-x48m-gp6r-gp4v/ (Markdown: https://insights.sbomify.com/GHSA-x48m-gp6r-gp4v/index.md)","id":"GHSA-x48m-gp6r-gp4v","markdown":"https://insights.sbomify.com/GHSA-x48m-gp6r-gp4v/index.md","name":"GHSA-x48m-gp6r-gp4v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"npm package","requires_auth":"none","summary":"Attackers can execute malicious code and modify dependencies via a compromised npm package, requiring developers to upgrade immediately.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Version 1.0.3 of `rate-map`  contains malicious code. The malware breaks functionality of the `purescript-installer` package by rewriting code of the `dl-tar` dependency.\n\n## Recommendation\n\nUpgrade to version 1.0.5 or later. There is no indication of further compromise.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Malicious Package in rate-map","id":"GHSA-x48m-gp6r-gp4v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["1.0.3"],"last_affected":[],"package":"rate-map","purl":null,"source":"GHSA-x48m-gp6r-gp4v"},{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["1.0.3"],"last_affected":[],"package":"rate-map","purl":"pkg:npm/rate-map","source":"GHSA-x48m-gp6r-gp4v"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute malicious code and modify dependencies via a compromised npm package, requiring developers to upgrade immediately.","url":"https://insights.sbomify.com/GHSA-x48m-gp6r-gp4v/"}