{"answers":{"affected":"2 open source packages ship an affected version, including willdurand/js-translation-bundle.","exploited":"There is no known exploitation of GHSA-x86x-qhf8-f37w in the wild and no public exploit code.","fix":"Upgrade willdurand/js-translation-bundle to 2.1.1 or later.","what":"GHSA-x86x-qhf8-f37w is a path traversal vulnerability in willdurand/js-translation-bundle, published on 7 Jun 2024. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-x86x-qhf8-f37w and fix it if it is affected.\n\nWhat it is: GHSA-x86x-qhf8-f37w is a path traversal vulnerability in willdurand/js-translation-bundle, published on 7 Jun 2024. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-x86x-qhf8-f37w in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- willdurand/js-translation-bundle (Packagist): affected all versions; fixed in 2.1.1\n- willdurand/js-translation-bundle (Packagist): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-x86x-qhf8-f37w/ (Markdown: https://insights.sbomify.com/GHSA-x86x-qhf8-f37w/index.md)","id":"GHSA-x86x-qhf8-f37w","markdown":"https://insights.sbomify.com/GHSA-x86x-qhf8-f37w/index.md","name":"GHSA-x86x-qhf8-f37w","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony translation bundle","requires_auth":"unknown","summary":"Attackers can exploit path traversal and code injection flaws in this Symfony bundle to execute arbitrary code or read sensitive files.","user_interaction":"unknown","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A path traversal and a javascript code injection vulnerabilities were identified in willdurand/js-translation-bundle versions prior to 2.1.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"willdurand/js-translation-bundle potential path traversal attack and remote code injection","id":"GHSA-x86x-qhf8-f37w","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"willdurand/js-translation-bundle","purl":null,"source":"GHSA-x86x-qhf8-f37w"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"willdurand/js-translation-bundle","purl":"pkg:composer/willdurand/js-translation-bundle","source":"GHSA-x86x-qhf8-f37w"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit path traversal and code injection flaws in this Symfony bundle to execute arbitrary code or read sensitive files.","url":"https://insights.sbomify.com/GHSA-x86x-qhf8-f37w/"}