# GHSA-x9p2-77v6-6vhf: FrankenPHP has delayed propagation of security fixes in upstream base images

> FrankenPHP images failed to auto-update base layers, exposing users to upstream vulnerabilities like RCE in libcrypto3 until manual rebuilds or pipeline fixes.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2026
- **Also known as:** GO-2026-4442

## What is GHSA-x9p2-77v6-6vhf?

GHSA-x9p2-77v6-6vhf is a vulnerability in github.com/dunglas/frankenphp, published on 5 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

# Delayed propagation of security fixes in upstream base images

## Summary

**Vulnerability in base Docker images (PHP, Go, and Alpine) not automatically propagating to FrankenPHP images.**

FrankenPHP's container images were previously built only when specific version tags were updated or when manual triggers were initiated. This meant that if an upstream base image (such as Alpine Linux or official PHP/Go images) received a security patch under an existing tag, the FrankenPHP image would remain on the older, vulnerable version of those base layers.

## Impact

Users pulling FrankenPHP images may have been running environments with known vulnerabilities in underlying system libraries (e.g., `libcrypto3`) even if they were using the "latest" version of a specific FrankenPHP tag.

Specifically, this includes vulnerabilities recently patched in **Alpine 3.20.9, 3.21.6, 3.22.3, and 3.23.3**, such as **CVE-2025-15467** (Remote Code Execution in `libcrypto3`).

## Details

The issue was a lack of automated "staleness" detection in the CI/CD pipeline.

Unless explicitly told, our build server was building new Docker images only when a new tag for base images was created. However, base images such as Alpine, PHP, and Go usually overwrite existing Docker tags to apply security fixes, which wasn't triggering a new build on our side.

## Patches

As of **February 4, 2026**, the CI/CD pipeline has been updated.

* **Automated Detection:** A daily check is now performed to compare the digest of local base images against upstream registries.
* **Auto-Rebuild:** If a change is detected in base images (even if the tag name remains the same), FrankenPHP images are automatically rebuilt and re-pushed.

**Users are advised to pull the latest versions of their specific tags to receive these updates.**

## Workarounds

You can force a local rebuild of your environment using the `--pull` flag to ensure you are fetching the latest patched base layers:

```bash
docker pull dunglas/frankenphp:latest
# If building your own image based on FrankenPHP
docker build --pull -t my-app .
```

## References

* [Alpine Linux Security Advisories](https://www.alpinelinux.org/posts/Alpine-3.20.9-3.21.6-3.22.3-3.23.3-released.html)
* **CVE-2025-15467** (RCE in libcrypto3)

## Credits

Thanks to [Tim Nelles](https://timnelles.de/) for reporting and fixing this issue.

## Which versions are affected by GHSA-x9p2-77v6-6vhf?

3 open source packages ship an affected version, including github.com/dunglas/frankenphp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dunglas/frankenphp` | Go | All versions | None |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.1.11 |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.1.11 |

## How do I fix GHSA-x9p2-77v6-6vhf?

Upgrade github.com/dunglas/frankenphp to 1.1.11 or later.

## Is GHSA-x9p2-77v6-6vhf being exploited?

There is no known exploitation of GHSA-x9p2-77v6-6vhf in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-x9p2-77v6-6vhf and fix it if it is affected.

What it is: GHSA-x9p2-77v6-6vhf is a vulnerability in github.com/dunglas/frankenphp, published on 5 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-x9p2-77v6-6vhf in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/dunglas/frankenphp (Go): affected all versions; no fix listed
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.1.11
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-x9p2-77v6-6vhf/ (Markdown: https://insights.sbomify.com/GHSA-x9p2-77v6-6vhf/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-x9p2-77v6-6vhf

---
From sbomify Insights: https://insights.sbomify.com/GHSA-x9p2-77v6-6vhf/
Summaries are generated and may contain mistakes; the official description above is the record.
