{"answers":{"affected":"2 open source packages ship an affected version, including @eslint/plugin-kit.","exploited":"There is no known exploitation of GHSA-xffm-g5w8-qvg7 in the wild and no public exploit code.","fix":"Upgrade @eslint/plugin-kit to 0.3.4 or later.","what":"GHSA-xffm-g5w8-qvg7 is a denial of service vulnerability in @eslint/plugin-kit, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-xffm-g5w8-qvg7 and fix it if it is affected.\n\nWhat it is: GHSA-xffm-g5w8-qvg7 is a denial of service vulnerability in @eslint/plugin-kit, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-xffm-g5w8-qvg7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @eslint/plugin-kit (npm): affected all versions; fixed in 0.3.4\n- @eslint/plugin-kit (npm): affected all versions; fixed in 0.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xffm-g5w8-qvg7/ (Markdown: https://insights.sbomify.com/GHSA-xffm-g5w8-qvg7/index.md)","id":"GHSA-xffm-g5w8-qvg7","markdown":"https://insights.sbomify.com/GHSA-xffm-g5w8-qvg7/index.md","name":"GHSA-xffm-g5w8-qvg7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"ESLint plugin kit","requires_auth":"none","summary":"Attackers can cause denial of service via high CPU usage by submitting crafted input to the ConfigCommentParser in the ESLint plugin kit library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n\nThe `ConfigCommentParser#parseJSONLikeConfig` API is vulnerable to a Regular Expression Denial of Service (ReDoS) attack in its only argument.\n\n### Details\n\nThe regular expression at [packages/plugin-kit/src/config-comment-parser.js:158](https://github.com/eslint/rewrite/blob/bd4bf23c59f0e4886df671cdebd5abaeb1e0d916/packages/plugin-kit/src/config-comment-parser.js#L158) is vulnerable to a quadratic runtime attack because the grouped expression is not anchored. This can be solved by prepending the regular expression with `[^-a-zA-Z0-9/]`.\n\n### PoC\n\n```javascript\nconst { ConfigCommentParser } = require(\"@eslint/plugin-kit\");\n\nconst str = `${\"A\".repeat(1000000)}?: 1 B: 2`;\n\nconsole.log(\"start\")\nvar parser = new ConfigCommentParser();\nconsole.log(parser.parseJSONLikeConfig(str));\nconsole.log(\"end\")\n\n// run `npm i @eslint/plugin-kit@0.3.3` and `node attack.js`\n// then the program will stuck forever with high CPU usage\n```\n\n### Impact\n\nThis is a Regular Expression Denial of Service attack which may lead to blocking execution and high CPU usage.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"@eslint/plugin-kit is vulnerable to Regular Expression Denial of Service attacks through ConfigCommentParser","id":"GHSA-xffm-g5w8-qvg7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.3.4"],"introduced":["0"],"last_affected":[],"package":"@eslint/plugin-kit","purl":null,"source":"GHSA-xffm-g5w8-qvg7"},{"ecosystem":"npm","fixed":["0.3.4"],"introduced":["0"],"last_affected":[],"package":"@eslint/plugin-kit","purl":"pkg:npm/%40eslint/plugin-kit","source":"GHSA-xffm-g5w8-qvg7"}],"products":null,"published":"2025-07-18","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service via high CPU usage by submitting crafted input to the ConfigCommentParser in the ESLint plugin kit library.","url":"https://insights.sbomify.com/GHSA-xffm-g5w8-qvg7/"}