{"answers":{"affected":"2 open source packages ship an affected version, including http-live-simulator.","exploited":"There is no known exploitation of GHSA-xgp2-cc4r-7vf6 in the wild and no public exploit code.","fix":"Upgrade http-live-simulator to 1.0.8 or later.","what":"GHSA-xgp2-cc4r-7vf6 is a denial of service vulnerability in http-live-simulator, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-xgp2-cc4r-7vf6 and fix it if it is affected.\n\nWhat it is: GHSA-xgp2-cc4r-7vf6 is a denial of service vulnerability in http-live-simulator, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-xgp2-cc4r-7vf6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- http-live-simulator (npm): affected all versions; fixed in 1.0.8\n- http-live-simulator (npm): affected all versions; fixed in 1.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xgp2-cc4r-7vf6/ (Markdown: https://insights.sbomify.com/GHSA-xgp2-cc4r-7vf6/index.md)","id":"GHSA-xgp2-cc4r-7vf6","markdown":"https://insights.sbomify.com/GHSA-xgp2-cc4r-7vf6/index.md","name":"GHSA-xgp2-cc4r-7vf6","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP simulator","requires_auth":"none","summary":"An attacker can crash the server by sending a specific HTTP request due to unhandled exceptions in the http-live-simulator library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `http-live-simulator` prior to 1.0.8 are vulnerable to Denial of Service. The package fails to catch an exception that causes the Node process to crash, effectively shutting down the server. This allows an attacker to send an HTTP request that crashes the server.\n\n## Recommendation\n\nUpgrade to version 1.0.8 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in http-live-simulator","id":"GHSA-xgp2-cc4r-7vf6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"http-live-simulator","purl":null,"source":"GHSA-xgp2-cc4r-7vf6"},{"ecosystem":"npm","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"http-live-simulator","purl":"pkg:npm/http-live-simulator","source":"GHSA-xgp2-cc4r-7vf6"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can crash the server by sending a specific HTTP request due to unhandled exceptions in the http-live-simulator library.","url":"https://insights.sbomify.com/GHSA-xgp2-cc4r-7vf6/"}