{"answers":{"affected":"2 open source packages ship an affected version, including foreman.","exploited":"There is no known exploitation of GHSA-xm28-fw2x-fqv2 in the wild and no public exploit code.","fix":"Upgrade foreman to 3.0.1 or later.","what":"GHSA-xm28-fw2x-fqv2 is a denial of service vulnerability in foreman, published on 31 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-xm28-fw2x-fqv2 and fix it if it is affected.\n\nWhat it is: GHSA-xm28-fw2x-fqv2 is a denial of service vulnerability in foreman, published on 31 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-xm28-fw2x-fqv2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- foreman (npm): affected all versions; fixed in 3.0.1\n- foreman (npm): affected all versions; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xm28-fw2x-fqv2/ (Markdown: https://insights.sbomify.com/GHSA-xm28-fw2x-fqv2/index.md)","id":"GHSA-xm28-fw2x-fqv2","markdown":"https://insights.sbomify.com/GHSA-xm28-fw2x-fqv2/index.md","name":"GHSA-xm28-fw2x-fqv2","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Foreman provisioning tool","requires_auth":"none","summary":"Attackers can cause a denial of service in Foreman by sending specially crafted requests with malicious paths.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"All versions of `foreman` are vulnerable to Regular Expression Denial of Service when requests to it are made with a specially crafted path.\n\n## Recommendation\n\nUpgrade to version 3.0.1.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in foreman","id":"GHSA-xm28-fw2x-fqv2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"foreman","purl":null,"source":"GHSA-xm28-fw2x-fqv2"},{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"foreman","purl":"pkg:npm/foreman","source":"GHSA-xm28-fw2x-fqv2"}],"products":null,"published":"2019-05-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause a denial of service in Foreman by sending specially crafted requests with malicious paths.","url":"https://insights.sbomify.com/GHSA-xm28-fw2x-fqv2/"}