# GHSA-xmp3-7745-g4vj: ezsystems/ez-support-tools Failing access control in system info view

> Low-privilege users can access sensitive system information, including phpinfo output, by bypassing access controls via direct links.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2024

## What is GHSA-xmp3-7745-g4vj?

GHSA-xmp3-7745-g4vj is a missing authorization vulnerability in ezsystems/ez-support-tools, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This Security Advisory is about a vulnerability in ezsystems/ez-support-tools v2.2, part of Ibexa DXP v3.2. Older versions are not affected. A user having insufficient permissions is able to access the system information tabs if they type in the direct link (the link is not shown in the menu). The "Setup / System info" policy should be required to access it, but only backend login is actually required. This means any editor can see core system information, including the output from phpinfo(). The fix ensures that the access policy is correctly verified.

## Which versions are affected by GHSA-xmp3-7745-g4vj?

2 open source packages ship an affected version, including ezsystems/ez-support-tools.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ez-support-tools` | Packagist | From 2.2.0 | 2.2.3 |
| `ezsystems/ez-support-tools` | Packagist | From 2.2.0 | 2.2.3 |

## How do I fix GHSA-xmp3-7745-g4vj?

Upgrade ezsystems/ez-support-tools to 2.2.3 or later.

## Is GHSA-xmp3-7745-g4vj being exploited?

There is no known exploitation of GHSA-xmp3-7745-g4vj in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-xmp3-7745-g4vj and fix it if it is affected.

What it is: GHSA-xmp3-7745-g4vj is a missing authorization vulnerability in ezsystems/ez-support-tools, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-xmp3-7745-g4vj in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ez-support-tools (Packagist): affected from 2.2.0; fixed in 2.2.3
- ezsystems/ez-support-tools (Packagist): affected from 2.2.0; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-xmp3-7745-g4vj/ (Markdown: https://insights.sbomify.com/GHSA-xmp3-7745-g4vj/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-xmp3-7745-g4vj

---
From sbomify Insights: https://insights.sbomify.com/GHSA-xmp3-7745-g4vj/
Summaries are generated and may contain mistakes; the official description above is the record.
