# GHSA-xmrp-424f-vfpx: SQLx Binary Protocol Misinterpretation caused by Truncating or Overflowing Casts

> An integer overflow in SQLx allows attackers to smuggle queries via oversized inputs, potentially leading to code execution or data modification.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Aug 2024
- **Also known as:** RUSTSEC-2024-0363

## What is GHSA-xmrp-424f-vfpx?

GHSA-xmrp-424f-vfpx is a vulnerability in sqlx, published on 15 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The following presentation at this year's DEF CON was brought to our attention on the SQLx Discord:

> SQL Injection isn't Dead: Smuggling Queries at the Protocol Level  
> <http://web.archive.org/web/20240812130923/https://media.defcon.org/DEF%20CON%2032/DEF%20CON%2032%20presentations/DEF%20CON%2032%20-%20Paul%20Gerste%20-%20SQL%20Injection%20Isn't%20Dead%20Smuggling%20Queries%20at%20the%20Protocol%20Level.pdf>  
> (Archive link for posterity.)

Essentially, encoding a value larger than 4GiB can cause the length prefix in the protocol to overflow, 
causing the server to interpret the rest of the string as binary protocol commands or other data.

It appears SQLx _does_ perform truncating casts in a way that could be problematic, 
for example: <https://github.com/launchbadge/sqlx/blob/6f2905695b9606b5f51b40ce10af63ac9e696bb8/sqlx-postgres/src/arguments.rs#L163>

This code has existed essentially since the beginning, 
so it is reasonable to assume that all published versions `<= 0.8.0` are affected.

## Mitigation

As always, you should make sure your application is validating untrustworthy user input. 
Reject any input over 4 GiB, or any input that could _encode_ to a string longer than 4 GiB. 
Dynamically built queries are also potentially problematic if it pushes the message size over this 4 GiB bound.

[`Encode::size_hint()`](https://docs.rs/sqlx/latest/sqlx/trait.Encode.html#method.size_hint) 
can be used for sanity checks, but do not assume that the size returned is accurate. 
For example, the `Json<T>` and `Text<T>` adapters have no reasonable way to predict or estimate the final encoded size, 
so they just return `size_of::<T>()` instead.

For web application backends, consider adding some middleware that limits the size of request bodies by default.

## Resolution

Work has started on a branch to add `#[deny]` directives for the following Clippy lints:

* [`cast_possible_truncation`](https://rust-lang.github.io/rust-clippy/master/#/cast_possible_truncation)
* [`cast_possible_wrap`](https://rust-lang.github.io/rust-clippy/master/#/cast_possible_wrap)
* [`cast_sign_loss`](https://rust-lang.github.io/rust-clippy/master/#/cast_sign_loss)

and to manually audit the code that they flag.

A fix is expected to be included in the `0.8.1` release (still WIP as of writing).

## Which versions are affected by GHSA-xmrp-424f-vfpx?

3 open source packages ship an affected version, including sqlx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlx` | crates.io | All versions | 0.8.1 |
| `sqlx` | crates.io | All versions | 0.8.1 |
| `sqlx` | crates.io | From 0.0.0-0 | 0.8.1 |

## How do I fix GHSA-xmrp-424f-vfpx?

Upgrade sqlx to 0.8.1 or later.

## Is GHSA-xmrp-424f-vfpx being exploited?

There is no known exploitation of GHSA-xmrp-424f-vfpx in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-xmrp-424f-vfpx and fix it if it is affected.

What it is: GHSA-xmrp-424f-vfpx is a vulnerability in sqlx, published on 15 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-xmrp-424f-vfpx in the wild and no public exploit code.

Affected packages and fixed versions:
- sqlx (crates.io): affected all versions; fixed in 0.8.1
- sqlx (crates.io): affected all versions; fixed in 0.8.1
- sqlx (crates.io): affected from 0.0.0-0; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-xmrp-424f-vfpx/ (Markdown: https://insights.sbomify.com/GHSA-xmrp-424f-vfpx/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-xmrp-424f-vfpx

---
From sbomify Insights: https://insights.sbomify.com/GHSA-xmrp-424f-vfpx/
Summaries are generated and may contain mistakes; the official description above is the record.
